Monthly Archives: May 2017

L2TPv3 Interworking

L2TPv3 Interworking

Layer 2 VPN (L2VPN) Interworking allows you to connect disparate attachment circuits. You can connect various types of L2 networks (Ethernet, VLAN, Frame Relay, ATM, PPP etc.) over L2TPV3. But it is supported on specific routers and line cards only. You can check Cisco documentation for specific requirements.

Here we will connect Site-1 Ethernet link to Site-2 Serial PPP link.

Topology

Configuration
R1 - Provider Edge Router connected to Customer Routers

hostname R1
!
ip cef
!
pseudowire-class PW-CLASS
 encapsulation l2tpv3
 interworking ip
 ip local interface Loopback0
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.13.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/1
 description To Cust-A Site-1 R4
 no ip address
 no keepalive
 xconnect 10.1.1.2 101 pw-class PW-CLASS
!
router ospf 1
 log-adjacency-changes
 network 10.1.0.0 0.0.255.255 area 0
!

R2 - Provider Edge Router connected to Customer Routers

hostname R2
!
ip cef
!
pseudowire-class PW-CLASS
 encapsulation l2tpv3
 interworking ip
 ip local interface Loopback0
!
interface Loopback0
 ip address 10.1.1.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.23.2 255.255.255.0
 ip ospf network point-to-point
!
interface Serial1/0
 description To Cust-A Site-2 R5
 no ip address
 encapsulation ppp
 serial restart-delay 0
 xconnect 10.1.1.1 101 pw-class PW-CLASS
!
router ospf 1
 log-adjacency-changes
 network 10.1.0.0 0.0.255.255 area 0
!

R3 - Service Provider Core Network Router

hostname R3
!
ip cef
!
interface FastEthernet0/0
 ip address 10.1.13.3 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/1
 ip address 10.1.23.3 255.255.255.0
 ip ospf network point-to-point
!
router ospf 1
 log-adjacency-changes
 network 10.1.0.0 0.0.255.255 area 0
!

R4 - Customer-A Site-1 Edge Router

hostname R4
!
interface FastEthernet0/0
 ip address 172.16.4.4 255.255.255.0
!
interface FastEthernet0/1
 ip address 172.16.45.1 255.255.255.252
!
router eigrp 100
 network 172.16.0.0
!

R5 - Customer-A Site-2 Edge Router

hostname R5
!
interface FastEthernet0/0
 ip address 172.16.5.5 255.255.255.0
!
interface Serial1/0
 ip address 172.16.45.2 255.255.255.252
 encapsulation ppp
 serial restart-delay 0
!
router eigrp 100
 network 172.16.0.0
!
Verification & Testing
R1#show l2tun tunnel all 

L2TP Tunnel Information Total tunnels 1 sessions 1

Tunnel id 3964089202 is up, remote id is 2104878685, 1 active sessions
  Locally initiated tunnel
  Tunnel state is established, time since change 00:36:16
  Tunnel transport is IP  (115)
  Remote tunnel name is R2
    Internet Address 10.1.1.2, port 0
  Local tunnel name is R1
    Internet Address 10.1.1.1, port 0
  L2TP class for tunnel is l2tp_default_class
  Counters, taking last clear into account:
    475 packets sent, 475 received
    28562 bytes sent, 28524 received
    Last clearing of counters never
  Counters, ignoring last clear:
    475 packets sent, 475 received
    28562 bytes sent, 28524 received
  Control Ns 37, Nr 9
  Local RWS 1024 (default), Remote RWS 1024
  Control channel Congestion Control is disabled
  Tunnel PMTU checking disabled
  Retransmission time 1, max 1 seconds
  Unsent queuesize 0, max 0
  Resend queuesize 0, max 3
  Total resends 1, ZLB ACKs sent 5
  Total out-of-order dropped pkts 0 
  Total out-of-order reorder pkts 0 
  Total peer authentication failures 0
  Current no session pak queue check 0 of 5
  Retransmit time distribution: 0 1 0 0 0 0 0 0 0 
  Control message authentication is disabled

R1#show l2tun session all 

L2TP Session Information Total tunnels 1 sessions 1

Session id 2788289264 is up, logical session id 32768, tunnel id 3964089202
  Remote session id is 1736473654, remote tunnel id 2104878685
  Locally initiated session
  Unique ID is 1
Session Layer 2 circuit, type is Ethernet, name is FastEthernet0/1
  Session vcid is 101
  Interworking type is IP
  Circuit state is UP
    Local circuit state is UP
    Remote circuit state is UP
Call serial number is 959200001
Remote tunnel name is R2
  Internet address is 10.1.1.2
Local tunnel name is R1
  Internet address is 10.1.1.1
IP protocol 115
  Session is L2TP signaled
  Session state is established, time since change 00:36:35
    479 Packets sent, 480 received
    28802 Bytes sent, 28824 received
  Last clearing of counters never
  Counters, ignoring last clear:
    479 Packets sent, 480 received
    28802 Bytes sent, 28824 received
    Receive packets dropped:
      out-of-order:             0
      other:                    0
      total:                    0
    Send packets dropped:
      exceeded session MTU:     0
      other:                    0
      total:                    0
  DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
  Sending UDP checksums are disabled
  Received UDP checksums are verified
  No session cookie information available
  FS cached header information:
    encap size = 24 bytes
    45000014 00000000 ff73a572 0a010101
    0a010102 67807c36 
  Sequencing is off
  Conditional debugging is disabled
  SSM switch id is 4096, SSM segment id is 8193


R2#show l2tun tunnel all

L2TP Tunnel Information Total tunnels 1 sessions 1

Tunnel id 2104878685 is up, remote id is 3964089202, 1 active sessions
  Remotely initiated tunnel
  Tunnel state is established, time since change 00:36:54
  Tunnel transport is IP  (115)
  Remote tunnel name is R1
    Internet Address 10.1.1.1, port 0
  Local tunnel name is R2
    Internet Address 10.1.1.2, port 0
  L2TP class for tunnel is l2tp_default_class
  Counters, taking last clear into account:
    484 packets sent, 484 received
    29064 bytes sent, 29102 received
    Last clearing of counters never
  Counters, ignoring last clear:
    484 packets sent, 484 received
    29064 bytes sent, 29102 received
  Control Ns 9, Nr 37
  Local RWS 1024 (default), Remote RWS 1024
  Control channel Congestion Control is disabled
  Tunnel PMTU checking disabled
  Retransmission time 1, max 1 seconds
  Unsent queuesize 0, max 0
  Resend queuesize 0, max 3
  Total resends 0, ZLB ACKs sent 34
  Total out-of-order dropped pkts 0 
  Total out-of-order reorder pkts 0 
  Total peer authentication failures 0
  Current no session pak queue check 0 of 5
  Retransmit time distribution: 0 0 0 0 0 0 0 0 0 
  Control message authentication is disabled

R2#show l2tun session all 

L2TP Session Information Total tunnels 1 sessions 1

Session id 1736473654 is up, logical session id 65537, tunnel id 2104878685
  Remote session id is 2788289264, remote tunnel id 3964089202
  Remotely initiated session
  Unique ID is 1
Session Layer 2 circuit, type is PPP, name is Serial1/0
  Session vcid is 101
  Interworking type is IP
  Circuit state is UP
    Local circuit state is UP
    Remote circuit state is UP
Call serial number is 959200001
Remote tunnel name is R1
  Internet address is 10.1.1.1
Local tunnel name is R2
  Internet address is 10.1.1.2
IP protocol 115
  Session is L2TP signaled
  Session state is established, time since change 00:37:08
    487 Packets sent, 487 received
    29244 Bytes sent, 29282 received
  Last clearing of counters never
  Counters, ignoring last clear:
    487 Packets sent, 487 received
    29244 Bytes sent, 29282 received
    Receive packets dropped:
      out-of-order:             0
      other:                    0
      total:                    0
    Send packets dropped:
      exceeded session MTU:     0
      other:                    0
      total:                    0
  DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
  Sending UDP checksums are disabled
  Received UDP checksums are verified
  No session cookie information available
  FS cached header information:
    encap size = 24 bytes
    45000014 00000000 ff73a572 0a010102
    0a010101 a631eaf0 
  Sequencing is off
  Conditional debugging is disabled
  SSM switch id is 4096, SSM segment id is 8193

R4#sh int f0/1
FastEthernet0/1 is up, line protocol is up 
  Hardware is i82543 (Livengood), address is ca03.3344.0006 (bia ca03.3344.0006)
  Internet address is 172.16.45.1/30
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     785 packets input, 58107 bytes
     Received 8 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     1219 packets output, 103455 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

R5#sh int s1/0
Serial1/0 is up, line protocol is up 
  Hardware is M4T
  Internet address is 172.16.45.2/30
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP, CDPCP, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters 01:00:27
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops) 
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1515 packets input, 61892 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1585 packets output, 82294 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R4#ping 172.16.45.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.45.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/94/148 ms

R4#show ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   172.16.45.2             Fa0/1             11 01:00:21  199  1194  0  3

R4#show ip route | beg Gate
Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
C        172.16.4.0/24 is directly connected, FastEthernet0/0
L        172.16.4.4/32 is directly connected, FastEthernet0/0
D        172.16.5.0/24 [90/30720] via 172.16.45.2, 01:00:42, FastEthernet0/1
C        172.16.45.0/30 is directly connected, FastEthernet0/1
L        172.16.45.1/32 is directly connected, FastEthernet0/1

R4#ping 172.16.5.5 source 172.16.4.4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.5.5, timeout is 2 seconds:
Packet sent with a source address of 172.16.4.4 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/76/168 ms

 

L2TPv3 – Layer 2 Tunneling Protocol Version 3

L2TPv3 – Layer 2 Tunneling Protocol Version 3

L2TPv3 provides the capabilities to tunnel Layer 2 payload over IP network.  When L2TPv3 is implemented, the physical interfaces that are connected to the customer’s network are used as tunnel ingress and egress interfaces. It is documented in RFC3931.

L2TP is comprised of two types of messages, control messages and data messages.Control messages are used in the establishment, maintenance, and clearing of control connections and sessions.  These messages utilize a reliable control channel within L2TP to guarantee delivery.  Data messages are used to encapsulate the L2 traffic being carried over the L2TP session.  Unlike control messages, data messages are not re-transmitted when packet loss occurs.

L2TPv3 Header Format

The session identifier identifies the tunnel context at the decapsulating router. The session ID of 0 is reserved for use by the protocol. Static L2TPv3 sessions need manual configuration of session ID on the PE routers. However, for dynamic L2TPv3 tunnel setup, the session IDs can be chosen depending on the number of tunnels that are supported by the router in question.

The cookie contains the key for the L2TPv3 session. The cookie length can be configured on a router, but the default value for the cookie length is 4 bytes. When the originating and terminating routers are different platforms, the cookie length needs to be configured manually to be 4 bytes.

Pseudowire control encapsulation consists of 4 bytes and implements sequencing with the L2TPv3 tunnel. It uses only the first bit and bits 8 through 31. The value of the first bit defines if bits 8 through 31 contain a sequence number and if it needs to be updated.

L2TPv3 Components
Control Connection

An L2TP control connection is a reliable control channel that is used to establish, maintain, and release individual L2TP sessions as well as the control connection itself.

Control Message

Control channel messages are used for signalling between the two routers that are the endpoints of the L2TPv3 pseudowire. These endpoints can be referred to as L2TP Control Connection Endpoints – LCCEs. Control connection messages can be used by the LCCEs to setup the control connection itself, to establish L2TPv3 sessions, to indicate circuit status changes, to tear down sessions, to terminate the control connection, and to provide a keepalive mechanism.

Data Channel

The channel for L2TP-encapsulated data traffic that passes between two LCCEs over IP Network.

Data Message

Data channel messages, on the other hand, are the messages that actually carry the Layer-2 protocols and connections over the IP backbone.

Pseudowire (PW)

It is an emulated circuit as it traverses a IP network.There is one Pseudowire per L2TP Session.

Network Topology

We will use following topology to configure L2TPv3 and extend Layer2 network from R4 to R5 and from R6 to R7.

Configuring L2TPv3 Static/Manual Tunnels
R1 - Provider Edge Router connected to Customer Routers

hostname R1
!
ip cef
!
!! -- L2TP class implements a template for control channel -- !!
!! -- parameters that can be applied to different pseudowire -- !!
!! -- classes on the router -- !!
l2tp-class L2TP-CLASS
 cookie size 4
!
!! -- Pseudowire class defines the session level parameters of -- !!
!! -- the L2TPV3 sessions -- !!
pseudowire-class PW-CLASS
 !! -- Data Encapsulation Protocol -- !!
 encapsulation l2tpv3
 !! -- No signaling protocol for Static Tunnels -- !!
 protocol none
 !! -- Configure the Source Address of the Tunnel -- !!
 ip local interface Loopback0
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.13.1 255.255.255.0
 ip ospf network point-to-point
 duplex full
 speed 100
!
interface FastEthernet0/1
 description To Cust-A Site-1 R4
 no ip address
 no cdp enable
 xconnect 10.1.1.2 101 encapsulation l2tpv3 manual pw-class PW-CLASS
  l2tp id 101 101
  l2tp cookie local 4 1
  l2tp cookie remote 4 1
  l2tp hello L2TP-CLASS
!
interface Serial1/0
 description To Cust-B Site-1 R6
 no ip address
 encapsulation ppp
 serial restart-delay 0
 no cdp enable
 xconnect 10.1.1.2 102 encapsulation l2tpv3 manual pw-class PW-CLASS
  l2tp id 102 102
  l2tp cookie local 4 1
  l2tp cookie remote 4 1
  l2tp hello L2TP-CLASS
!
router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
!

R2 - Provider Edge Router connected to Customer Routers

hostname R2
!
ip cef
!
l2tp-class L2TP-CLASS
 cookie size 4
!
pseudowire-class PW-CLASS
 encapsulation l2tpv3
 protocol none
 ip local interface Loopback0
!
interface Loopback0
 ip address 10.1.1.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.23.2 255.255.255.0
 ip ospf network point-to-point
 duplex full
 speed 100
!
interface FastEthernet0/1
 description To Cust-A Site-2 R5
 no ip address
 no cdp enable
 xconnect 10.1.1.1 101 encapsulation l2tpv3 manual pw-class PW-CLASS
  l2tp id 101 101
  l2tp cookie local 4 1
  l2tp cookie remote 4 1
  l2tp hello L2TP-CLASS
!
interface Serial1/0
 description To Cust-B Site-2 R6
 no ip address
 encapsulation ppp
 serial restart-delay 0
 no cdp enable
 xconnect 10.1.1.1 102 encapsulation l2tpv3 manual pw-class PW-CLASS
  l2tp id 102 102
  l2tp cookie local 4 1
  l2tp cookie remote 4 1
  l2tp hello L2TP-CLASS
!
router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
!

R3 - Provider Core Network Router

hostname R3
!
ip cef
!
interface FastEthernet0/0
 ip address 10.1.13.3 255.255.255.0
 ip ospf network point-to-point
 duplex full
 speed 100
!
interface FastEthernet0/1
 ip address 10.1.23.3 255.255.255.0
 ip ospf network point-to-point
 duplex full
 speed 100
!
router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
!

R4 - Customer-A Site-1 Edge Router

hostname R4
!
interface FastEthernet0/0
 ip address 172.16.4.4 255.255.255.0
!
interface FastEthernet0/1
 ip address 172.16.45.1 255.255.255.252
!
router eigrp 100
 network 172.16.0.0
!

R5 - Customer-A Site-2 Edge Router

hostname R5
!
interface FastEthernet0/0
 ip address 172.16.5.5 255.255.255.0
!
interface FastEthernet0/1
 ip address 172.16.45.2 255.255.255.252
!
router eigrp 100
 network 172.16.0.0
!

R6 - Customer-B Site-1 Edge Router

hostname R6
!
interface FastEthernet0/0
 ip address 192.168.6.6 255.255.255.0
!
interface Serial1/0
 ip address 192.168.67.1 255.255.255.252
 encapsulation ppp
 serial restart-delay 0
!
router eigrp 100
 network 192.168.0.0 0.0.255.255
!

R7 - Customer-B Site-2 Edge Router

hostname R7
!
interface FastEthernet0/0
 ip address 192.168.7.7 255.255.255.0
!
interface Serial1/0
 ip address 192.168.67.2 255.255.255.252
 encapsulation ppp
 serial restart-delay 0
!
router eigrp 100
 network 192.168.0.0 0.0.255.255
!
Verification & Testing
R1#show ip route | beg Gate
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.1.1.1/32 is directly connected, Loopback0
O        10.1.1.2/32 [110/3] via 10.1.13.3, 00:11:24, FastEthernet0/0
C        10.1.13.0/24 is directly connected, FastEthernet0/0
L        10.1.13.1/32 is directly connected, FastEthernet0/0
O        10.1.23.0/24 [110/2] via 10.1.13.3, 00:11:24, FastEthernet0/0

R2#show ip route | beg Gate
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O        10.1.1.1/32 [110/3] via 10.1.23.3, 00:11:35, FastEthernet0/0
C        10.1.1.2/32 is directly connected, Loopback0
O        10.1.13.0/24 [110/2] via 10.1.23.3, 00:11:45, FastEthernet0/0
C        10.1.23.0/24 is directly connected, FastEthernet0/0
L        10.1.23.2/32 is directly connected, FastEthernet0/0

R3#show ip route | beg Gate
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O        10.1.1.1/32 [110/2] via 10.1.13.1, 00:11:54, FastEthernet0/0
O        10.1.1.2/32 [110/2] via 10.1.23.2, 00:11:54, FastEthernet0/1
C        10.1.13.0/24 is directly connected, FastEthernet0/0
L        10.1.13.3/32 is directly connected, FastEthernet0/0
C        10.1.23.0/24 is directly connected, FastEthernet0/1
L        10.1.23.3/32 is directly connected, FastEthernet0/1


R1#show l2tun tunnel all 

L2TP Tunnel Information Total tunnels 1 sessions 2

Tunnel id 4276657069 is up, remote id is 1806975601, 2 active sessions
  Locally initiated tunnel
  Tunnel state is established, time since change 00:12:34
  Tunnel transport is IP  (115)
  Remote tunnel name is R2
    Internet Address 10.1.1.2, port 0
  Local tunnel name is R1
    Internet Address 10.1.1.1, port 0
  L2TP class for tunnel is L2TP-CLASS
  Counters, taking last clear into account:
    0 packets sent, 0 received
    0 bytes sent, 0 received
    Last clearing of counters never
  Counters, ignoring last clear:
    0 packets sent, 0 received
    0 bytes sent, 0 received
  Control Ns 3, Nr 13
  Local RWS 1024 (default), Remote RWS 1024
  Control channel Congestion Control is disabled
  Tunnel PMTU checking disabled
  Retransmission time 1, max 1 seconds
  Unsent queuesize 0, max 0
  Resend queuesize 0, max 1
  Total resends 0, ZLB ACKs sent 12
  Total out-of-order dropped pkts 0 
  Total out-of-order reorder pkts 0 
  Total peer authentication failures 0
  Current no session pak queue check 0 of 5
  Retransmit time distribution: 0 0 0 0 0 0 0 0 0 
  Control message authentication is disabled

R2#show l2tun tunnel all 

L2TP Tunnel Information Total tunnels 1 sessions 2

Tunnel id 1806975601 is up, remote id is 4276657069, 2 active sessions
  Remotely initiated tunnel
  Tunnel state is established, time since change 00:13:47
  Tunnel transport is IP  (115)
  Remote tunnel name is R1
    Internet Address 10.1.1.1, port 0
  Local tunnel name is R2
    Internet Address 10.1.1.2, port 0
  L2TP class for tunnel is L2TP-CLASS
  Counters, taking last clear into account:
    0 packets sent, 0 received
    0 bytes sent, 0 received
    Last clearing of counters never
  Counters, ignoring last clear:
    0 packets sent, 0 received
    0 bytes sent, 0 received
  Control Ns 14, Nr 3
  Local RWS 1024 (default), Remote RWS 1024
  Control channel Congestion Control is disabled
  Tunnel PMTU checking disabled
  Retransmission time 1, max 1 seconds
  Unsent queuesize 0, max 0
  Resend queuesize 0, max 1
  Total resends 0, ZLB ACKs sent 2
  Total out-of-order dropped pkts 0 
  Total out-of-order reorder pkts 0 
  Total peer authentication failures 0
  Current no session pak queue check 0 of 5
  Retransmit time distribution: 0 0 0 0 0 0 0 0 0 
  Control message authentication is disabled

R1#show l2tun session all 

L2TP Session Information Total tunnels 1 sessions 2

Session id 102 is up, logical session id 65548, tunnel id 4276657069
  Remote session id is 102, remote tunnel id 1806975601
  Locally initiated session
  Unique ID is 4
Session Layer 2 circuit, type is PPP, name is Serial1/0
  Session vcid is 102
  Circuit state is UP
    Local circuit state is UP
    Remote circuit state is UP
Call serial number is 0
Remote tunnel name is 
  Internet address is 10.1.1.2
Local tunnel name is 
  Internet address is 10.1.1.1
IP protocol 115
  Session is manually signaled
  Session state is established, time since change 00:15:06
    408 Packets sent, 406 received
    20885 Bytes sent, 20891 received
  Last clearing of counters never
  Counters, ignoring last clear:
    408 Packets sent, 406 received
    20885 Bytes sent, 20891 received
    Receive packets dropped:
      out-of-order:             0
      other:                    0
      total:                    0
    Send packets dropped:
      exceeded session MTU:     0
      other:                    0
      total:                    0
  DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
  Sending UDP checksums are disabled
  Received UDP checksums are verified
  Session cookie information:
    local cookie, size 4 bytes, value 00 00 00 01 
    remote cookie, size 4 bytes, value 00 00 00 01 
  FS cached header information:
    encap size = 28 bytes
    45000014 00000000 ff73a572 0a010101
    0a010102 00000066 00000001 
  Sequencing is off
  Conditional debugging is disabled
  SSM switch id is 8200, SSM segment id is 16405

Session id 101 is up, logical session id 32778, tunnel id 4276657069
  Remote session id is 101, remote tunnel id 1806975601
  Locally initiated session
  Unique ID is 1
Session Layer 2 circuit, type is Ethernet, name is FastEthernet0/1
  Session vcid is 101
  Circuit state is UP
    Local circuit state is UP
    Remote circuit state is UP
Call serial number is 0
Remote tunnel name is 
  Internet address is 10.1.1.2
Local tunnel name is 
  Internet address is 10.1.1.1
IP protocol 115
  Session is manually signaled
  Session state is established, time since change 00:15:06
    315 Packets sent, 310 received
    26766 Bytes sent, 26400 received
  Last clearing of counters never
  Counters, ignoring last clear:
    315 Packets sent, 310 received
    26766 Bytes sent, 26400 received
    Receive packets dropped:
      out-of-order:             0
      other:                    0
      total:                    0
    Send packets dropped:
      exceeded session MTU:     0
      other:                    0
      total:                    0
  DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
  Sending UDP checksums are disabled
  Received UDP checksums are verified
  Session cookie information:
    local cookie, size 4 bytes, value 00 00 00 01 
    remote cookie, size 4 bytes, value 00 00 00 01 
  FS cached header information:
    encap size = 28 bytes
    45000014 00000000 ff73a572 0a010101
    0a010102 00000065 00000001 
  Sequencing is off
  Conditional debugging is disabled
  SSM switch id is 4102, SSM segment id is 12308


R2#show l2tun session all

L2TP Session Information Total tunnels 1 sessions 2

Session id 102 is up, logical session id 65548, tunnel id 1806975601
  Remote session id is 102, remote tunnel id 4276657069
  Locally initiated session
  Unique ID is 4
Session Layer 2 circuit, type is PPP, name is Serial1/0
  Session vcid is 102
  Circuit state is UP
    Local circuit state is UP
    Remote circuit state is UP
Call serial number is 0
Remote tunnel name is 
  Internet address is 10.1.1.1
Local tunnel name is 
  Internet address is 10.1.1.2
IP protocol 115
  Session is manually signaled
  Session state is established, time since change 00:15:56
    433 Packets sent, 427 received
    22397 Bytes sent, 21989 received
  Last clearing of counters never
  Counters, ignoring last clear:
    433 Packets sent, 427 received
    22397 Bytes sent, 21989 received
    Receive packets dropped:
      out-of-order:             0
      other:                    0
      total:                    0
    Send packets dropped:
      exceeded session MTU:     0
      other:                    0
      total:                    0
  DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
  Sending UDP checksums are disabled
  Received UDP checksums are verified
  Session cookie information:
    local cookie, size 4 bytes, value 00 00 00 01 
    remote cookie, size 4 bytes, value 00 00 00 01 
  FS cached header information:
    encap size = 28 bytes
    45000014 00000000 ff73a572 0a010102
    0a010101 00000066 00000001 
  Sequencing is off
  Conditional debugging is disabled
  SSM switch id is 8200, SSM segment id is 16405

Session id 101 is up, logical session id 32778, tunnel id 1806975601
  Remote session id is 101, remote tunnel id 4276657069
  Locally initiated session
  Unique ID is 1
Session Layer 2 circuit, type is Ethernet, name is FastEthernet0/1
  Session vcid is 101
  Circuit state is UP
    Local circuit state is UP
    Remote circuit state is UP
Call serial number is 0
Remote tunnel name is 
  Internet address is 10.1.1.1
Local tunnel name is 
  Internet address is 10.1.1.2
IP protocol 115
  Session is manually signaled
  Session state is established, time since change 00:15:56
    329 Packets sent, 330 received
    27997 Bytes sent, 28095 received
  Last clearing of counters never
  Counters, ignoring last clear:
    329 Packets sent, 330 received
    27997 Bytes sent, 28095 received
    Receive packets dropped:
      out-of-order:             0
      other:                    0
      total:                    0
    Send packets dropped:
      exceeded session MTU:     0
      other:                    0
      total:                    0
  DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
  Sending UDP checksums are disabled
  Received UDP checksums are verified
  Session cookie information:
    local cookie, size 4 bytes, value 00 00 00 01 
    remote cookie, size 4 bytes, value 00 00 00 01 
  FS cached header information:
    encap size = 28 bytes
    45000014 00000000 ff73a572 0a010102
    0a010101 00000065 00000001 
  Sequencing is off
  Conditional debugging is disabled
  SSM switch id is 4102, SSM segment id is 12307

!! -- Customer A Site-1 router can reach Site-2 Router WAN IP -- !!
!! -- through L2TPV3 tunneling over Service Provider IP network -- !!  

R4#ping 172.16.45.2 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 172.16.45.2, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 96/103/108 ms 

!! -- Customer A Site-1 Router would see Site-2 Router as -- !!
!! -- directly connected as they would be directly connected -- !!
!! -- on a layer 2 network -- !! 

R4#ping 172.16.45.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.45.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/103/108 ms

R4#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone, 
                  D - Remote, C - CVTA, M - Two-port Mac Relay 

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R5               Fas 0/1            145              R    7206VXR   Fas 0/1
R4#show ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   172.16.45.2             Fa0/1                    10 00:17:52 1605  5000  0  3
 
R4#show ip route | beg Gate      
Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
C        172.16.4.0/24 is directly connected, FastEthernet0/0
L        172.16.4.4/32 is directly connected, FastEthernet0/0
D        172.16.5.0/24 [90/30720] via 172.16.45.2, 00:18:16, FastEthernet0/1
C        172.16.45.0/30 is directly connected, FastEthernet0/1
L        172.16.45.1/32 is directly connected, FastEthernet0/1

R5#show ip route | beg Gate
Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
D        172.16.4.0/24 [90/30720] via 172.16.45.1, 00:22:24, FastEthernet0/1
C        172.16.5.0/24 is directly connected, FastEthernet0/0
L        172.16.5.5/32 is directly connected, FastEthernet0/0
C        172.16.45.0/30 is directly connected, FastEthernet0/1
L        172.16.45.2/32 is directly connected, FastEthernet0/1

R4#ping 172.16.5.5 source 172.16.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.5.5, timeout is 2 seconds:
Packet sent with a source address of 172.16.4.4 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/95/100 ms

R4#traceroute 172.16.5.5 source 172.16.4.4
Type escape sequence to abort.
Tracing the route to 172.16.5.5
VRF info: (vrf in name/id, vrf out name/id)
  1 172.16.45.2 100 msec *  92 msec

!! -- Customer B Site-1 router can reach Site-2 Router WAN IP -- !!
!! -- through L2TPV3 tunneling over Service Provider IP network -- !!  

R6#ping 192.168.67.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.67.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/105/116 ms

R6#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone, 
                  D - Remote, C - CVTA, M - Two-port Mac Relay 

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R7               Ser 1/0            136              R    7206VXR   Ser 1/0
R6#show ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   192.168.67.2            Se1/0                    14 00:22:46  140   840  0  3

R6#show ip route | beg Gate
Gateway of last resort is not set

      192.168.6.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.6.0/24 is directly connected, FastEthernet0/0
L        192.168.6.6/32 is directly connected, FastEthernet0/0
D     192.168.7.0/24 [90/2172416] via 192.168.67.2, 00:22:57, Serial1/0
      192.168.67.0/24 is variably subnetted, 3 subnets, 2 masks
C        192.168.67.0/30 is directly connected, Serial1/0
L        192.168.67.1/32 is directly connected, Serial1/0
C        192.168.67.2/32 is directly connected, Serial1/0

R6#ping 192.168.7.7 source 192.168.6.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.7, timeout is 2 seconds:
Packet sent with a source address of 192.168.6.6 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/103/112 ms

R6#traceroute 192.168.7.7 source 192.168.6.6
Type escape sequence to abort.
Tracing the route to 192.168.7.7
VRF info: (vrf in name/id, vrf out name/id)
  1 192.168.67.2 92 msec *  104 msec
Configuring L2TPv3 Dynamic Tunnels

The only differences are in the configuration of the pseudowire class or template as well as the attachment circuit configuration. In comparison to implementation of static/manual L2TPV3 tunnel configuration, Dynamic L2TPV3 Tunnel configuration is the configuration of a protocol for signalling the control channel parameters.  We used “protocol none” (no signalling protocol) in pseudowire-class with static/manual tunnel configuration. We will not use this command with Dynamic tunnel configuration. By default it will use L2TP for signalling here.

R1 - Provider Edge Router connected to Customer Routers

hostname R1
!
ip cef
!
pseudowire-class PW-CLASS
 encapsulation l2tpv3
 ip local interface Loopback0
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.13.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/1
 description To Cust-A Site-1 R4
 no ip address
 no cdp enable
 xconnect 10.1.1.2 101 pw-class PW-CLASS
!
interface Serial1/0
 description To Cust-B Site-1 R6
 no ip address
 encapsulation ppp
 no cdp enable
 xconnect 10.1.1.2 102 pw-class PW-CLASS
!
router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
!

R2 - Provider Edge Router connected to Customer Routers
hostname R2
!
ip cef
!
pseudowire-class PW-CLASS
 encapsulation l2tpv3
 ip local interface Loopback0
!
interface Loopback0
 ip address 10.1.1.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.23.2 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/1
 description To Cust-A Site-2 R5
 no ip address
 no cdp enable
 xconnect 10.1.1.1 101 pw-class PW-CLASS
!
interface Serial1/0
 description To Cust-B Site-2 R7
 no ip address
 encapsulation ppp
 no cdp enable
 xconnect 10.1.1.1 102 pw-class PW-CLASS
!
router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
!
Verification & Testing
R1#show l2tun tunnel all 

L2TP Tunnel Information Total tunnels 1 sessions 2

Tunnel id 1776971907 is up, remote id is 329857833, 2 active sessions
  Remotely initiated tunnel
  Tunnel state is established, time since change 00:04:40
  Tunnel transport is IP  (115)
  Remote tunnel name is R2
    Internet Address 10.1.1.2, port 0
  Local tunnel name is R1
    Internet Address 10.1.1.1, port 0
  L2TP class for tunnel is l2tp_default_class
  Counters, taking last clear into account:
    235 packets sent, 232 received
    15766 bytes sent, 15568 received
    Last clearing of counters never
  Counters, ignoring last clear:
    235 packets sent, 232 received
    15766 bytes sent, 15568 received
  Control Ns 5, Nr 11
  Local RWS 1024 (default), Remote RWS 1024
  Control channel Congestion Control is disabled
  Tunnel PMTU checking disabled
  Retransmission time 1, max 1 seconds
  Unsent queuesize 0, max 0
  Resend queuesize 0, max 2
  Total resends 0, ZLB ACKs sent 8
  Total out-of-order dropped pkts 0 
  Total out-of-order reorder pkts 0 
  Total peer authentication failures 0
  Current no session pak queue check 0 of 5
  Retransmit time distribution: 0 0 0 0 0 0 0 0 0 
  Control message authentication is disabled

R1#show l2tun session all 

L2TP Session Information Total tunnels 1 sessions 2

Session id 1211541847 is up, logical session id 98324, tunnel id 1776971907
  Remote session id is 132911511, remote tunnel id 329857833 
  Remotely initiated session
  Unique ID is 4
Session Layer 2 circuit, type is PPP, name is Serial1/0
  Session vcid is 102
  Circuit state is UP
    Local circuit state is UP
    Remote circuit state is UP
Call serial number is 1898000001
Remote tunnel name is R2
  Internet address is 10.1.1.2
Local tunnel name is R1
  Internet address is 10.1.1.1
IP protocol 115
  Session is L2TP signaled
  Session state is established, time since change 00:05:01
    142 Packets sent, 142 received
    7563 Bytes sent, 7583 received
  Last clearing of counters never
  Counters, ignoring last clear:
    142 Packets sent, 142 received
    7563 Bytes sent, 7583 received
    Receive packets dropped:
      out-of-order:             0
      other:                    0
      total:                    0
    Send packets dropped:
      exceeded session MTU:     0
      other:                    0
      total:                    0
  DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
  Sending UDP checksums are disabled
  Received UDP checksums are verified
  No session cookie information available
  FS cached header information:
    encap size = 24 bytes
    45000014 00000000 ff73a572 0a010101
    0a010102 07ec1197 
  Sequencing is off
  Conditional debugging is disabled
  SSM switch id is 8198, SSM segment id is 12312

Session id 2531932146 is up, logical session id 65558, tunnel id 1776971907
  Remote session id is 490732246, remote tunnel id 329857833 
  Remotely initiated session
  Unique ID is 1
Session Layer 2 circuit, type is Ethernet, name is FastEthernet0/1
  Session vcid is 101
  Circuit state is UP
    Local circuit state is UP
    Remote circuit state is UP
Call serial number is 1898000002
Remote tunnel name is R2
  Internet address is 10.1.1.2
Local tunnel name is R1
  Internet address is 10.1.1.1
IP protocol 115
  Session is L2TP signaled
  Session state is established, time since change 00:05:01
    109 Packets sent, 106 received
    9059 Bytes sent, 8841 received
  Last clearing of counters never
  Counters, ignoring last clear:
    109 Packets sent, 106 received
    9059 Bytes sent, 8841 received
    Receive packets dropped:
      out-of-order:             0
      other:                    0
      total:                    0
    Send packets dropped:
      exceeded session MTU:     0
      other:                    0
      total:                    0
  DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
  Sending UDP checksums are disabled
  Received UDP checksums are verified
  No session cookie information available
  FS cached header information:
    encap size = 24 bytes
    45000014 00000000 ff73a572 0a010101
    0a010102 1d3ffad6 
  Sequencing is off
  Conditional debugging is disabled
  SSM switch id is 4100, SSM segment id is 16409


R2#show l2tun tunnel all 

L2TP Tunnel Information Total tunnels 1 sessions 2

Tunnel id 329857833 is up, remote id is 1776971907, 2 active sessions
  Locally initiated tunnel
  Tunnel state is established, time since change 00:06:02
  Tunnel transport is IP  (115)
  Remote tunnel name is R1
    Internet Address 10.1.1.1, port 0
  Local tunnel name is R2
    Internet Address 10.1.1.2, port 0
  L2TP class for tunnel is l2tp_default_class
  Counters, taking last clear into account:
    295 packets sent, 297 received
    19736 bytes sent, 19872 received
    Last clearing of counters never
  Counters, ignoring last clear:
    295 packets sent, 297 received
    19736 bytes sent, 19872 received
  Control Ns 13, Nr 5
  Local RWS 1024 (default), Remote RWS 1024
  Control channel Congestion Control is disabled
  Tunnel PMTU checking disabled
  Retransmission time 1, max 1 seconds
  Unsent queuesize 0, max 0
  Resend queuesize 0, max 3
  Total resends 0, ZLB ACKs sent 4
  Total out-of-order dropped pkts 0 
  Total out-of-order reorder pkts 0 
  Total peer authentication failures 0
  Current no session pak queue check 0 of 5
  Retransmit time distribution: 0 0 0 0 0 0 0 0 0 
  Control message authentication is disabled


R2#show l2tun session all 

L2TP Session Information Total tunnels 1 sessions 2

Session id 132911511 is up, logical session id 65548, tunnel id 329857833 
  Remote session id is 1211541847, remote tunnel id 1776971907
  Locally initiated session
  Unique ID is 4
Session Layer 2 circuit, type is PPP, name is Serial1/0
  Session vcid is 102
  Circuit state is UP
    Local circuit state is UP
    Remote circuit state is UP
Call serial number is 1898000001
Remote tunnel name is R1
  Internet address is 10.1.1.1
Local tunnel name is R2
  Internet address is 10.1.1.2
IP protocol 115
  Session is L2TP signaled
  Session state is established, time since change 00:06:16
    175 Packets sent, 174 received
    9117 Bytes sent, 9035 received
  Last clearing of counters never
  Counters, ignoring last clear:
    175 Packets sent, 174 received
    9117 Bytes sent, 9035 received
    Receive packets dropped:
      out-of-order:             0
      other:                    0
      total:                    0
    Send packets dropped:
      exceeded session MTU:     0
      other:                    0
      total:                    0
  DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
  Sending UDP checksums are disabled
  Received UDP checksums are verified
  No session cookie information available
  FS cached header information:
    encap size = 24 bytes
    45000014 00000000 ff73a572 0a010102
    0a010101 4836a957 
  Sequencing is off
  Conditional debugging is disabled
  SSM switch id is 8198, SSM segment id is 12310

Session id 490732246 is up, logical session id 32776, tunnel id 329857833 
  Remote session id is 2531932146, remote tunnel id 1776971907
  Locally initiated session
  Unique ID is 1
Session Layer 2 circuit, type is Ethernet, name is FastEthernet0/1
  Session vcid is 101
  Circuit state is UP
    Local circuit state is UP
    Remote circuit state is UP
Call serial number is 1898000002
Remote tunnel name is R1
  Internet address is 10.1.1.1
Local tunnel name is R2
  Internet address is 10.1.1.2
IP protocol 115
  Session is L2TP signaled
  Session state is established, time since change 00:06:16
    132 Packets sent, 135 received
    11203 Bytes sent, 11421 received
  Last clearing of counters never
  Counters, ignoring last clear:
    132 Packets sent, 135 received
    11203 Bytes sent, 11421 received
    Receive packets dropped:
      out-of-order:             0
      other:                    0
      total:                    0
    Send packets dropped:
      exceeded session MTU:     0
      other:                    0
      total:                    0
  DF bit off, ToS reflect disabled, ToS value 0, TTL value 255
  Sending UDP checksums are disabled
  Received UDP checksums are verified
  No session cookie information available
  FS cached header information:
    encap size = 24 bytes
    45000014 00000000 ff73a572 0a010102
    0a010101 96ea37f2 
  Sequencing is off
  Conditional debugging is disabled
  SSM switch id is 4100, SSM segment id is 16407

R4#ping 172.16.45.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.45.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/105/116 ms

R4#show ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   172.16.45.2             Fa0/1                    14 00:07:29  192  1152  0  3

R4#show ip route | beg Gate
Gateway of last resort is not set

      172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
C        172.16.4.0/24 is directly connected, FastEthernet0/0
L        172.16.4.4/32 is directly connected, FastEthernet0/0
D        172.16.5.0/24 [90/30720] via 172.16.45.2, 00:07:45, FastEthernet0/1
C        172.16.45.0/30 is directly connected, FastEthernet0/1
L        172.16.45.1/32 is directly connected, FastEthernet0/1

R6#ping 192.168.67.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.67.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/104/116 ms

R6#show ip eigrp neighbors 
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   192.168.67.2            Se1/0                    12 00:08:43  119   714  0  3

R6#show ip route | beg Gate
Gateway of last resort is not set

      192.168.6.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.6.0/24 is directly connected, FastEthernet0/0
L        192.168.6.6/32 is directly connected, FastEthernet0/0
D     192.168.7.0/24 [90/2172416] via 192.168.67.2, 00:08:50, Serial1/0
      192.168.67.0/24 is variably subnetted, 3 subnets, 2 masks
C        192.168.67.0/30 is directly connected, Serial1/0
L        192.168.67.1/32 is directly connected, Serial1/0
C        192.168.67.2/32 is directly connected, Serial1/0