Integrated IS-IS IPv4 Configuration

Integrated IS-IS for IPv4 Configuration

We will cover following topics:

  • Multiple IS-IS Areas
  • IS-IS Circuit Types
  • IS-IS Network Types
  • IS-IS Path Manipulation
  • Authentication
  • Route Leak between Areas
  • Route Summarization
  • Redistribution between IS-IS and other routing protocol
Network Topology

Tasks
  1. Configure IS-IS Area 49.0001 on R1, R2, R3 & R4.
  2. Configure IS-IS Area 49.0002 on R5, R6 & R7.
  3. Configure IS-IS Area 49.0003 on R8 & R9.
  4. Configure OSPF Area 0 between R1 Fa0/1 and R10 Fa0/1.
  5. Configure R1, R2 & R3 as IS-IS Router type Level-2 only.
  6. Configure all interfaces of R4 as IS-IS circuit type Level-2 only.
  7. R5, R6 & R8 would work in default IS-IS router type, which is L1/L2.
  8. Configure R7 & R9 as IS-IS Router type Level-1.
  9. Configure mutual redistribution between OSPF and IS-IS on R1.
  10. R7 has two equal cost default route to reach networks outside its own IS-IS Area. Increase the IS-IS link cost between R7 & R6 so that it would prefer path via R7 & R5.
  11. Configure R8 to Leak Level-2 area routes into Level-1 area.
  12. Configure R8 to send summary route 172.16.0.0/22 instead of more specific routes from 172.16.x.x network, into Level-1 area.
  13. Configure IS-IS link type point-to-point between R5 & R7.
  14. Configure IS-IS clear text authentication on link between R2 & R5.
  15. Configure IS-IS MD5 authentication on link between R4 & R6.
Configuration
R1:

hostname R1
!
ip cef
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.123.1 255.255.255.0
 ip router isis 1
!
interface FastEthernet0/1
 ip address 172.16.110.1 255.255.255.0
!
router ospf 1
 redistribute isis 1 level-1-2 subnets
 passive-interface default
 no passive-interface FastEthernet0/1
 network 172.16.110.1 0.0.0.0 area 0
 network 192.168.1.1 0.0.0.0 area 0
!
router isis 1
 net 49.0001.1921.6800.1001.00
 is-type level-2-only
 redistribute ospf 1 match internal external 1 external 2
 passive-interface Loopback0
!

R2:

hostname R2
!
ip cef
!
key chain CLEAR-TEXT-KC
 key 1
 key-string UNENCRYPTEDKEY
!
interface Loopback0
 ip address 192.168.1.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.123.2 255.255.255.0
 ip router isis 1
!
interface FastEthernet0/1
 ip address 10.1.25.2 255.255.255.0
 ip router isis 1
 isis authentication mode text
 isis authentication key-chain CLEAR-TEXT-KC
!
interface FastEthernet1/0
 ip address 10.1.24.2 255.255.255.0
 ip router isis 1
!
router isis 1
 net 49.0001.1921.6800.1002.00
 is-type level-2-only
 passive-interface Loopback0
!

R3:

hostname R3
!
ip cef
!
interface Loopback0
 ip address 192.168.1.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.123.3 255.255.255.0
 ip router isis 1
!
interface FastEthernet0/1
 ip address 10.1.38.3 255.255.255.0
 ip router isis 1
!
interface FastEthernet1/0
 ip address 10.1.34.3 255.255.255.0
 ip router isis 1
!
router isis 1
 net 49.0001.1921.6800.1003.00
 is-type level-2-only
 passive-interface Loopback0
!

R4:

hostname R4
!
ip cef
!
key chain MD5-SECURED-KC
 key 1
 key-string ENCRYPTEDKEY
!
interface Loopback0
 ip address 192.168.1.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.34.4 255.255.255.0
 ip router isis 1
 isis circuit-type level-2-only
!
interface FastEthernet0/1
 ip address 10.1.46.4 255.255.255.0
 ip router isis 1
 isis circuit-type level-2-only
 isis authentication mode md5
 isis authentication key-chain MD5-SECURED-KC
!
interface FastEthernet1/0
 ip address 10.1.24.4 255.255.255.0
 ip router isis 1
 isis circuit-type level-2-only
!
router isis 1
 net 49.0001.1921.6800.1004.00
 passive-interface Loopback0
!

R5:

hostname R5
!
ip cef
!
key chain CLEAR-TEXT-KC
 key 1
 key-string UNENCRYPTEDKEY
!
interface Loopback0
 ip address 192.168.1.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.57.5 255.255.255.0
 ip router isis 1
 isis network point-to-point 
!
interface FastEthernet0/1
 ip address 10.1.25.5 255.255.255.0
 ip router isis 1
 isis authentication mode text
 isis authentication key-chain CLEAR-TEXT-KC
!
interface FastEthernet1/0
 ip address 10.1.56.5 255.255.255.0
 ip router isis 1
!
router isis 1
 net 49.0002.1921.6800.1005.00
 passive-interface Loopback0
!

R6:

hostname R6
!
ip cef
!
key chain MD5-SECURED-KC
 key 1
 key-string ENCRYPTEDKEY
!
interface Loopback0
 ip address 192.168.1.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.67.6 255.255.255.0
 ip router isis 1
!
interface FastEthernet0/1
 ip address 10.1.46.6 255.255.255.0
 ip router isis 1
 isis authentication mode md5
 isis authentication key-chain MD5-SECURED-KC
!
interface FastEthernet1/0
 ip address 10.1.56.6 255.255.255.0
 ip router isis 1
!
router isis 1
 net 49.0002.1921.6800.1006.00
 passive-interface Loopback0
!

R7:

hostname R7
!
ip cef
!
interface Loopback0
 ip address 192.168.1.7 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.57.7 255.255.255.0
 ip router isis 1
 isis network point-to-point 
!
interface FastEthernet0/1
 ip address 10.1.67.7 255.255.255.0
 ip router isis 1
 isis metric 20
!
router isis 1
 net 49.0002.1921.6800.1007.00
 is-type level-1
 passive-interface Loopback0
!

R8:

hostname R8
!
ip cef
!
interface Loopback0
 ip address 192.168.1.8 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.89.8 255.255.255.0
 ip router isis 1
!
interface FastEthernet0/1
 ip address 10.1.38.8 255.255.255.0
 ip router isis 1
!
router isis 1
 net 49.0003.1921.6800.1008.00
 summary-address 172.16.0.0 255.255.252.0 level-1
 redistribute isis ip level-2 into level-1 distribute-list 100
 passive-interface Loopback0
!

R9:

hostname R9
!
ip cef
!
interface Loopback0
 ip address 192.168.1.9 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.89.9 255.255.255.0
 ip router isis 1
!
router isis 1
 net 49.0003.1921.6800.1009.00
 is-type level-1
 passive-interface Loopback0
!

R10:

hostname R10
!
ip cef
!
interface Loopback0
 ip address 192.168.1.10 255.255.255.255
!
interface Loopback1
 ip address 172.16.0.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback2
 ip address 172.16.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback3
 ip address 172.16.2.1 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback4
 ip address 172.16.3.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/1
 ip address 172.16.110.10 255.255.255.0
!
router ospf 1
 network 0.0.0.0 255.255.255.255 area 0
!

Task Specific Configuration Explanation
Task 1 – 3

We can configure router isis with or without tag. Tag is similar to OSPF process ID.

Without tag:

router isis
net xxxxxxxxx
interface x/y
ip router isis

With Tag:

router isis 1
net xxxxxxxxx
interface x/y
ip router isis 1

“passive-interface Loopback0” means the IP network configured under loopback will be advertised to IS-IS neighbors but no neighborship adjacency will be attempted.

Task 5

By default, IS-IS routes acts as Level1 and Level2 router. We can change it with “is-type” command under “router isis” configuration.

Example:
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router isis 1
R1(config-router)#is-type ?
 level-1      Act as a station router only
 level-1-2    Act as both a station router and an area router
 level-2-only Act as an area router only
Task 6

By default, IS-IS router acting as Level1 and Level2 router, will try to establish adjacencies for both Level1 and Level2. We can change the default behavior at interface level also.

Example:
R1(config-if)#int f0/0 
R1(config-if)#isis circuit-type ?
 level-1      Level-1 only adjacencies are formed
 level-1-2    Level-1-2 adjacencies are formed
 level-2-only Level-2 only adjacencies are formed
 <cr>
Task 9

OSPF to IS-IS Redistribution

We need to define which OSPF routes need to be redistributed into IS-IS. Here we have matched all OSPF route types – internal, external type 1 (E1), external type 2 (E2)

router isis 1
 redistribute ospf 1 match internal external 1 external 2

IS-IS to OSPF Redistribution

We need to define which IS-IS routes need to be redistributed into OSPF. Here we have matched both level1 and level2 routes with their actual subnet mask.

router ospf 1
 redistribute isis 1 level-1-2 subnets
Task 10

R7 has two equal cost default route to send traffic out of area as both the links Fa0/0 & Fa0/1 have same metric 10, which is default.

R7#sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
 Known via "isis", distance 115, metric 10, candidate default path, type level-1
 Redistributing via isis 1
 Last update from 10.1.67.6 on FastEthernet0/1, 00:00:15 ago
 Routing Descriptor Blocks:
 10.1.67.6, from 192.168.1.6, 00:00:15 ago, via FastEthernet0/1
 Route metric is 10, traffic share count is 1
 * 10.1.57.5, from 192.168.1.5, 00:00:15 ago, via FastEthernet0/0
 Route metric is 10, traffic share count is 1

Let’s configure metric value 20 on link Fa0/1.

R7#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R7(config)#int f0/1
R7(config-if)#isis metric 20
R7(config-if)#end 

R7#sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
 Known via "isis", distance 115, metric 10, candidate default path, type level-1
 Redistributing via isis 1
 Last update from 10.1.57.5 on FastEthernet0/0, 00:00:19 ago
 Routing Descriptor Blocks:
 * 10.1.57.5, from 192.168.1.5, 00:00:19 ago, via FastEthernet0/0
 Route metric is 10, traffic share count is 1

R7#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R7(config)#int f0/0
R7(config-if)#shut
R7(config-if)#
*Sep 12 22:37:25.343: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
*Sep 12 22:37:26.343: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
R7(config-if)#do sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
 Known via "isis", distance 115, metric 20, candidate default path, type level-1
 Redistributing via isis 1
 Last update from 10.1.67.6 on FastEthernet0/1, 00:00:06 ago
 Routing Descriptor Blocks:
 * 10.1.67.6, from 192.168.1.6, 00:00:06 ago, via FastEthernet0/1
 Route metric is 20, traffic share count is 1
R7(config-if)#no shut
R7(config-if)#
*Sep 12 22:37:49.991: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
R7(config-if)#
*Sep 12 22:37:50.991: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R7(config-if)#do sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
 Known via "isis", distance 115, metric 10, candidate default path, type level-1
 Redistributing via isis 1
 Last update from 10.1.57.5 on FastEthernet0/0, 00:00:15 ago
 Routing Descriptor Blocks:
 * 10.1.57.5, from 192.168.1.5, 00:00:15 ago, via FastEthernet0/0
 Route metric is 10, traffic share count is 1
Task 11

We can say IS-IS level1 area is like OSPF totally stubby area, which receives default route from ABR router to reach all destinations outside of its own area. Let’s check routing table on R9 (Level-1 Router) before leaking level2 routes into level1 area.

R9#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 + - replicated route, % - next hop override

Gateway of last resort is 10.1.89.8 to network 0.0.0.0

i*L1 0.0.0.0/0 [115/10] via 10.1.89.8, 00:59:01, FastEthernet0/0
 10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L1 10.1.38.0/24 [115/20] via 10.1.89.8, 00:59:01, FastEthernet0/0
C 10.1.89.0/24 is directly connected, FastEthernet0/0
L 10.1.89.9/32 is directly connected, FastEthernet0/0
 192.168.1.0/32 is subnetted, 2 subnets
i L1 192.168.1.8 [115/10] via 10.1.89.8, 00:59:01, FastEthernet0/0
C 192.168.1.9 is directly connected, Loopback0

Let’s configure route leak level2 routes into level1 on R8. We can use extended access-list or route-map to match routes, which we want to leak from level2 into level1. Here we used access-list 100 to match all level2 routes.

R8#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R8(config)#access-list 100 permit ip any any
R8(config)#router isis 1
R8(config-router)#redistribute isis ip level-2 into level-1 distribute-list 100 
R8(config-router)#end
R8#

Now check routing on R9(Level1 Router)

R9#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 + - replicated route, % - next hop override

Gateway of last resort is 10.1.89.8 to network 0.0.0.0

i*L1 0.0.0.0/0 [115/10] via 10.1.89.8, 01:08:13, FastEthernet0/0
 10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
i ia 10.1.24.0/24 [115/168] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 10.1.25.0/24 [115/168] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 10.1.34.0/24 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
i L1 10.1.38.0/24 [115/20] via 10.1.89.8, 01:08:13, FastEthernet0/0
i ia 10.1.46.0/24 [115/168] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 10.1.56.0/24 [115/178] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 10.1.57.0/24 [115/178] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 10.1.67.0/24 [115/178] via 10.1.89.8, 00:02:50, FastEthernet0/0
C 10.1.89.0/24 is directly connected, FastEthernet0/0
L 10.1.89.9/32 is directly connected, FastEthernet0/0
i ia 10.1.123.0/24 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
 172.16.0.0/24 is subnetted, 5 subnets
i ia 172.16.0.0 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 172.16.1.0 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 172.16.2.0 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 172.16.3.0 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 172.16.110.0 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
 192.168.1.0/32 is subnetted, 10 subnets
i ia 192.168.1.1 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 192.168.1.2 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 192.168.1.3 [115/148] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 192.168.1.4 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 192.168.1.5 [115/168] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 192.168.1.6 [115/168] via 10.1.89.8, 00:02:50, FastEthernet0/0
i ia 192.168.1.7 [115/178] via 10.1.89.8, 00:02:50, FastEthernet0/0
i L1 192.168.1.8 [115/10] via 10.1.89.8, 01:08:13, FastEthernet0/0
C 192.168.1.9 is directly connected, Loopback0
i ia 192.168.1.10 [115/158] via 10.1.89.8, 00:02:50, FastEthernet0/0
R9#
Task 12

As we have seen in previous routing table on R9, it has received four routes from 172.16.x.x network, which can be summarized into 172.16.0.0/22.

Let’s configure route summarization on R8, which is advertising these routes to R9 via route leaking.

R8#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R8(config)#router isis 1 
R8(config-router)#summary-address 172.16.0.0 255.255.252.0 ? 
 level-1   Summarize into level-1 area
 level-1-2 Summarize into both area and sub-domain
 level-2   Summarize into level-2 sub-domain
 metric    Set metric for summay route
 tag       Set tag
 <cr>

R8(config-router)#summary-address 172.16.0.0 255.255.252.0 level-1
R8(config-router)#end
R8#


!! -- When doing manual summarization the router will add a local --!!
!!-- summary route to null 0. This feature is in place to prevent --!! 
!! -- routing loops. --!!

R8#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 + - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
i L2 10.1.24.0/24 [115/30] via 10.1.38.3, 01:16:28, FastEthernet0/1
i L2 10.1.25.0/24 [115/30] via 10.1.38.3, 01:16:28, FastEthernet0/1
i L2 10.1.34.0/24 [115/20] via 10.1.38.3, 01:16:28, FastEthernet0/1
C 10.1.38.0/24 is directly connected, FastEthernet0/1
L 10.1.38.8/32 is directly connected, FastEthernet0/1
i L2 10.1.46.0/24 [115/30] via 10.1.38.3, 01:16:28, FastEthernet0/1
i L2 10.1.56.0/24 [115/40] via 10.1.38.3, 01:16:18, FastEthernet0/1
i L2 10.1.57.0/24 [115/40] via 10.1.38.3, 01:16:28, FastEthernet0/1
i L2 10.1.67.0/24 [115/40] via 10.1.38.3, 01:16:18, FastEthernet0/1
C 10.1.89.0/24 is directly connected, FastEthernet0/0
L 10.1.89.8/32 is directly connected, FastEthernet0/0
i L2 10.1.123.0/24 [115/20] via 10.1.38.3, 01:16:28, FastEthernet0/1
 172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
i su 172.16.0.0/22 [115/20] via 0.0.0.0, 00:03:02, Null0
i L2 172.16.0.0/24 [115/20] via 10.1.38.3, 01:15:46, FastEthernet0/1
i L2 172.16.1.0/24 [115/20] via 10.1.38.3, 01:15:46, FastEthernet0/1
i L2 172.16.2.0/24 [115/20] via 10.1.38.3, 01:15:46, FastEthernet0/1
i L2 172.16.3.0/24 [115/20] via 10.1.38.3, 01:15:46, FastEthernet0/1
i L2 172.16.110.0/24 [115/20] via 10.1.38.3, 01:16:18, FastEthernet0/1
 192.168.1.0/32 is subnetted, 10 subnets
i L2 192.168.1.1 [115/20] via 10.1.38.3, 01:16:18, FastEthernet0/1
i L2 192.168.1.2 [115/20] via 10.1.38.3, 01:16:28, FastEthernet0/1
i L2 192.168.1.3 [115/10] via 10.1.38.3, 01:16:28, FastEthernet0/1
i L2 192.168.1.4 [115/20] via 10.1.38.3, 01:16:28, FastEthernet0/1
i L2 192.168.1.5 [115/30] via 10.1.38.3, 01:16:28, FastEthernet0/1
i L2 192.168.1.6 [115/30] via 10.1.38.3, 01:16:18, FastEthernet0/1
i L2 192.168.1.7 [115/40] via 10.1.38.3, 00:20:48, FastEthernet0/1
C 192.168.1.8 is directly connected, Loopback0
i L1 192.168.1.9 [115/10] via 10.1.89.9, 01:16:28, FastEthernet0/0
i L2 192.168.1.10 [115/20] via 10.1.38.3, 01:15:46, FastEthernet0/1
R8#


!! -- Now check routing table on R9. -- !!

R9#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 + - replicated route, % - next hop override

Gateway of last resort is 10.1.89.8 to network 0.0.0.0

i*L1 0.0.0.0/0 [115/10] via 10.1.89.8, 01:14:25, FastEthernet0/0
 10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
i ia 10.1.24.0/24 [115/168] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 10.1.25.0/24 [115/168] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 10.1.34.0/24 [115/158] via 10.1.89.8, 00:09:02, FastEthernet0/0
i L1 10.1.38.0/24 [115/20] via 10.1.89.8, 01:14:25, FastEthernet0/0
i ia 10.1.46.0/24 [115/168] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 10.1.56.0/24 [115/178] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 10.1.57.0/24 [115/178] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 10.1.67.0/24 [115/178] via 10.1.89.8, 00:09:02, FastEthernet0/0
C 10.1.89.0/24 is directly connected, FastEthernet0/0
L 10.1.89.9/32 is directly connected, FastEthernet0/0
i ia 10.1.123.0/24 [115/158] via 10.1.89.8, 00:09:02, FastEthernet0/0
 172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
i ia 172.16.0.0/22 [115/158] via 10.1.89.8, 00:00:58, FastEthernet0/0
i ia 172.16.110.0/24 [115/158] via 10.1.89.8, 00:09:02, FastEthernet0/0
 192.168.1.0/32 is subnetted, 10 subnets
i ia 192.168.1.1 [115/158] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 192.168.1.2 [115/158] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 192.168.1.3 [115/148] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 192.168.1.4 [115/158] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 192.168.1.5 [115/168] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 192.168.1.6 [115/168] via 10.1.89.8, 00:09:02, FastEthernet0/0
i ia 192.168.1.7 [115/178] via 10.1.89.8, 00:09:02, FastEthernet0/0
i L1 192.168.1.8 [115/10] via 10.1.89.8, 01:14:25, FastEthernet0/0
C 192.168.1.9 is directly connected, Loopback0
i ia 192.168.1.10 [115/158] via 10.1.89.8, 00:09:02, FastEthernet0/0
R9#

Task 13 – 15  are self explanatory.

Final Verification and Testing
IS-IS Neighborship
  • “Type” column shows neighrborship type – L1, L2.
  • “Circuit Id” column shows the circuit id of DIS system on the link. Circtuit Id value would be Zero “00” on point-to-point link as there would not be any DIS on point-to-point link.

OSPF Neighborship between R1 and R10

CLNS Protocol and Interfaces
R1#show clns protocol

IS-IS Router: 1
 System Id: 1921.6800.1001.00 IS-Type: level-2
 Manual area address(es): 
 49.0001
 Routing for area address(es): 
 49.0001
 Interfaces supported by IS-IS:
 FastEthernet0/0 - IP
 Passive interface: 
 Loopback0
 Redistribute:
 static (on by default)
 Distance for L2 CLNS routes: 110
 RRR level: none
 Generate narrow metrics: level-1-2
 Accept narrow metrics: level-1-2
 Generate wide metrics: none
 Accept wide metrics: none

R1#show clns interface 
FastEthernet0/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 14 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x0, local circuit ID 0x1
 Level-2 Metric: 10, Priority: 64, Circuit ID: R3.01
 DR ID: R3.01
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 2
 Next IS-IS LAN Level-2 Hello in 649 milliseconds

R2#show clns protocol

IS-IS Router: 1
 System Id: 1921.6800.1002.00 IS-Type: level-2
 Manual area address(es): 
 49.0001
 Routing for area address(es): 
 49.0001
 Interfaces supported by IS-IS:
 FastEthernet1/0 - IP
 FastEthernet0/1 - IP
 FastEthernet0/0 - IP
 Passive interface: 
 Loopback0
 Redistribute:
 static (on by default)
 Distance for L2 CLNS routes: 110
 RRR level: none
 Generate narrow metrics: level-1-2
 Accept narrow metrics: level-1-2
 Generate wide metrics: none
 Accept wide metrics: none

R2#show clns interface
FastEthernet0/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 15 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x0, local circuit ID 0x1
 Level-2 Metric: 10, Priority: 64, Circuit ID: R3.01
 DR ID: R3.01
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 2
 Next IS-IS LAN Level-2 Hello in 1 seconds
FastEthernet0/1 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 37 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x1, local circuit ID 0x2
 Level-2 Metric: 10, Priority: 64, Circuit ID: R2.02
 DR ID: R2.02
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-2 Hello in 2 seconds
FastEthernet1/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 47 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x2, local circuit ID 0x3
 Level-2 Metric: 10, Priority: 64, Circuit ID: R4.03
 DR ID: R4.03
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-2 Hello in 1 seconds

R3#show clns protocol

IS-IS Router: 1
 System Id: 1921.6800.1003.00 IS-Type: level-2
 Manual area address(es): 
 49.0001
 Routing for area address(es): 
 49.0001
 Interfaces supported by IS-IS:
 FastEthernet1/0 - IP
 FastEthernet0/1 - IP
 FastEthernet0/0 - IP
 Passive interface: 
 Loopback0
 Redistribute:
 static (on by default)
 Distance for L2 CLNS routes: 110
 RRR level: none
 Generate narrow metrics: level-1-2
 Accept narrow metrics: level-1-2
 Generate wide metrics: none
 Accept wide metrics: none

R3#show clns interface
FastEthernet0/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 19 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x0, local circuit ID 0x1
 Level-2 Metric: 10, Priority: 64, Circuit ID: R3.01
 DR ID: R3.01
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 2
 Next IS-IS LAN Level-2 Hello in 734 milliseconds
FastEthernet0/1 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 21 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x1, local circuit ID 0x2
 Level-2 Metric: 10, Priority: 64, Circuit ID: R3.02
 DR ID: R3.02
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-2 Hello in 1 seconds
FastEthernet1/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 19 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x2, local circuit ID 0x3
 Level-2 Metric: 10, Priority: 64, Circuit ID: R3.03
 DR ID: R3.03
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-2 Hello in 1 seconds

R4#show clns protocol

IS-IS Router: 1
 System Id: 1921.6800.1004.00 IS-Type: level-1-2
 Manual area address(es): 
 49.0001
 Routing for area address(es): 
 49.0001
 Interfaces supported by IS-IS:
 FastEthernet1/0 - IP
 FastEthernet0/1 - IP
 FastEthernet0/0 - IP
 Passive interface: 
 Loopback0
 Redistribute:
 static (on by default)
 Distance for L2 CLNS routes: 110
 RRR level: none
 Generate narrow metrics: level-1-2
 Accept narrow metrics: level-1-2
 Generate wide metrics: none
 Accept wide metrics: none

R4#show clns interface
FastEthernet0/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 46 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-2
 Interface number 0x0, local circuit ID 0x1
 Level-2 Metric: 10, Priority: 64, Circuit ID: R3.03
 DR ID: R3.03
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-2 Hello in 8 seconds
FastEthernet0/1 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 30 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-2
 Interface number 0x1, local circuit ID 0x2
 Level-2 Metric: 10, Priority: 64, Circuit ID: R4.02
 DR ID: R4.02
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-2 Hello in 1 seconds
FastEthernet1/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 5 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-2
 Interface number 0x2, local circuit ID 0x3
 Level-2 Metric: 10, Priority: 64, Circuit ID: R4.03
 DR ID: R4.03
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-2 Hello in 1 seconds

R5#show clns protocol

IS-IS Router: 1
 System Id: 1921.6800.1005.00 IS-Type: level-1-2
 Manual area address(es): 
 49.0002
 Routing for area address(es): 
 49.0002
 Interfaces supported by IS-IS:
 FastEthernet1/0 - IP
 FastEthernet0/1 - IP
 FastEthernet0/0 - IP
 Passive interface: 
 Loopback0
 Redistribute:
 static (on by default)
 Distance for L2 CLNS routes: 110
 RRR level: none
 Generate narrow metrics: level-1-2
 Accept narrow metrics: level-1-2
 Generate wide metrics: none
 Accept wide metrics: none

R5#show clns interface
FastEthernet0/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 47 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x0, local circuit ID 0x100
 Neighbor System-ID: R7    <<<< Point-to-point link, no DIS
 Level-1 Metric: 10, Priority: 64, Circuit ID: R7.00
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 1
 Level-2 Metric: 10, Priority: 64, Circuit ID: R7.00
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 0
 Next IS-IS Hello in 1 seconds
 if state UP
FastEthernet0/1 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 16 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x1, local circuit ID 0x1
 Level-1 Metric: 10, Priority: 64, Circuit ID: R5.01
 DR ID: 0000.0000.0000.00      <<<< No L1 Adjacency
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 0
 Level-2 Metric: 10, Priority: 64, Circuit ID: R2.02
 DR ID: R2.02
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-1 Hello in 5 seconds
 Next IS-IS LAN Level-2 Hello in 7 seconds
FastEthernet1/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 41 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x2, local circuit ID 0x2
 Level-1 Metric: 10, Priority: 64, Circuit ID: R6.03
 DR ID: R6.03
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 1
 Level-2 Metric: 10, Priority: 64, Circuit ID: R6.03
 DR ID: R6.03
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-1 Hello in 7 seconds
 Next IS-IS LAN Level-2 Hello in 9 seconds


R6#show clns protocol

IS-IS Router: 1
 System Id: 1921.6800.1006.00 IS-Type: level-1-2
 Manual area address(es): 
 49.0002
 Routing for area address(es): 
 49.0002
 Interfaces supported by IS-IS:
 FastEthernet1/0 - IP
 FastEthernet0/1 - IP
 FastEthernet0/0 - IP
 Passive interface: 
 Loopback0
 Redistribute:
 static (on by default)
 Distance for L2 CLNS routes: 110
 RRR level: none
 Generate narrow metrics: level-1-2
 Accept narrow metrics: level-1-2
 Generate wide metrics: none
 Accept wide metrics: none

R6#show clns interface
FastEthernet0/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 4 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x0, local circuit ID 0x1
 Level-1 Metric: 10, Priority: 64, Circuit ID: R7.01
 DR ID: R7.01
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 1
 Level-2 Metric: 10, Priority: 64, Circuit ID: R6.01
 DR ID: 0000.0000.0000.00   <<<< No L2 Adjacency
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 0
 Next IS-IS LAN Level-1 Hello in 984 milliseconds
 Next IS-IS LAN Level-2 Hello in 1 seconds
FastEthernet0/1 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 38 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x1, local circuit ID 0x2
 Level-1 Metric: 10, Priority: 64, Circuit ID: R6.02
 DR ID: 0000.0000.0000.00     <<<< No L1 Adjacency
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 0
 Level-2 Metric: 10, Priority: 64, Circuit ID: R4.02
 DR ID: R4.02
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-1 Hello in 6 seconds
 Next IS-IS LAN Level-2 Hello in 575 milliseconds
FastEthernet1/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 30 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x2, local circuit ID 0x3
 Level-1 Metric: 10, Priority: 64, Circuit ID: R6.03
 DR ID: R6.03
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 1
 Level-2 Metric: 10, Priority: 64, Circuit ID: R6.03
 DR ID: R6.03
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-1 Hello in 1 seconds
 Next IS-IS LAN Level-2 Hello in 1 seconds

R7#show clns protocol

IS-IS Router: 1
 System Id: 1921.6800.1007.00 IS-Type: level-1
 Manual area address(es): 
 49.0002
 Routing for area address(es): 
 49.0002
 Interfaces supported by IS-IS:
 FastEthernet0/1 - IP
 FastEthernet0/0 - IP
 Passive interface: 
 Loopback0
 Redistribute:
 static (on by default)
 Distance for L2 CLNS routes: 110
 RRR level: none
 Generate narrow metrics: level-1-2
 Accept narrow metrics: level-1-2
 Generate wide metrics: none
 Accept wide metrics: none

!! -- We are using default metric (10) on Fa0/0 and defined metric--!! 
!! -- value 20 on Fa0/1. Router will prefer path via lowest metric--!!

R7#
!
interface FastEthernet0/0
 ip address 10.1.57.7 255.255.255.0
 ip router isis 1
!
interface FastEthernet0/1
 ip address 10.1.67.7 255.255.255.0
 ip router isis 1
 isis metric 20
!

R7#show clns interface
FastEthernet0/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 31 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x0, local circuit ID 0x100
 Neighbor System-ID: R5     <<<< Point-to-point link
 Level-1 Metric: 10, Priority: 64, Circuit ID: R7.00
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 1
 Next IS-IS Hello in 431 milliseconds
 if state UP
FastEthernet0/1 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 26 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x1, local circuit ID 0x1
 Level-1 Metric: 20, Priority: 64, Circuit ID: R7.01  
 DR ID: R7.01
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 1
 Next IS-IS LAN Level-1 Hello in 2 seconds

R8#show clns protocol

IS-IS Router: 1
 System Id: 1921.6800.1008.00 IS-Type: level-1-2
 Manual area address(es): 
 49.0003
 Routing for area address(es): 
 49.0003
 Interfaces supported by IS-IS:
 FastEthernet0/1 - IP
 FastEthernet0/0 - IP
 Passive interface: 
 Loopback0
 Redistribute:
 static (on by default)
 Distance for L2 CLNS routes: 110
 TID 0: Inter-area IP routes from L2 into L1 enabled with list 100
 RRR level: none
 Generate narrow metrics: level-1-2
 Accept narrow metrics: level-1-2
 Generate wide metrics: none
 Accept wide metrics: none

R8#show clns interface
FastEthernet0/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 26 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x0, local circuit ID 0x1
 Level-1 Metric: 10, Priority: 64, Circuit ID: R9.01
 DR ID: R9.01
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 1
 Level-2 Metric: 10, Priority: 64, Circuit ID: R8.01
 DR ID: 0000.0000.0000.00
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 0
 Next IS-IS LAN Level-1 Hello in 1 seconds
 Next IS-IS LAN Level-2 Hello in 1 seconds
FastEthernet0/1 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 22 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x1, local circuit ID 0x2
 Level-1 Metric: 10, Priority: 64, Circuit ID: R8.02
 DR ID: 0000.0000.0000.00
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 0
 Level-2 Metric: 10, Priority: 64, Circuit ID: R3.02
 DR ID: R3.02
 Level-2 IPv6 Metric: 10
 Number of active level-2 adjacencies: 1
 Next IS-IS LAN Level-1 Hello in 991 milliseconds
 Next IS-IS LAN Level-2 Hello in 7 seconds

R9#show clns protocol

IS-IS Router: 1
 System Id: 1921.6800.1009.00 IS-Type: level-1
 Manual area address(es): 
 49.0003
 Routing for area address(es): 
 49.0003
 Interfaces supported by IS-IS:
 FastEthernet0/0 - IP
 Passive interface: 
 Loopback0
 Redistribute:
 static (on by default)
 Distance for L2 CLNS routes: 110
 RRR level: none
 Generate narrow metrics: level-1-2
 Accept narrow metrics: level-1-2
 Generate wide metrics: none
 Accept wide metrics: none

R9#show clns interface
FastEthernet0/0 is up, line protocol is up
 Checksums enabled, MTU 1497, Encapsulation SAP
 ERPDUs enabled, min. interval 10 msec.
 CLNS fast switching enabled
 CLNS SSE switching disabled
 DEC compatibility mode OFF for this interface
 Next ESH/ISH in 20 seconds
 Routing Protocol: IS-IS
 Circuit Type: level-1-2
 Interface number 0x0, local circuit ID 0x1
 Level-1 Metric: 10, Priority: 64, Circuit ID: R9.01
 DR ID: R9.01
 Level-1 IPv6 Metric: 10
 Number of active level-1 adjacencies: 1
 Next IS-IS LAN Level-1 Hello in 2 seconds
Routing

R5, R6 and R8 are L1/L2 router and setting ATT bit to advertise default route to their respective L1 neighbor routers.

R1#show ip route 

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
 + - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
i L2 10.1.24.0/24 [115/20] via 10.1.123.2, 02:14:25, FastEthernet0/0
i L2 10.1.25.0/24 [115/20] via 10.1.123.2, 02:14:25, FastEthernet0/0
i L2 10.1.34.0/24 [115/20] via 10.1.123.3, 02:14:12, FastEthernet0/0
i L2 10.1.38.0/24 [115/20] via 10.1.123.3, 02:14:12, FastEthernet0/0
i L2 10.1.46.0/24 [115/30] via 10.1.123.3, 02:14:12, FastEthernet0/0
 [115/30] via 10.1.123.2, 02:14:12, FastEthernet0/0
i L2 10.1.56.0/24 [115/30] via 10.1.123.2, 02:14:12, FastEthernet0/0
i L2 10.1.57.0/24 [115/30] via 10.1.123.2, 02:14:12, FastEthernet0/0
i L2 10.1.67.0/24 [115/40] via 10.1.123.3, 02:14:02, FastEthernet0/0
 [115/40] via 10.1.123.2, 02:14:02, FastEthernet0/0
i L2 10.1.89.0/24 [115/30] via 10.1.123.3, 02:14:12, FastEthernet0/0
C 10.1.123.0/24 is directly connected, FastEthernet0/0
L 10.1.123.1/32 is directly connected, FastEthernet0/0
 172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
O 172.16.0.0/24 [110/2] via 172.16.110.10, 02:13:36, FastEthernet0/1
O 172.16.1.0/24 [110/2] via 172.16.110.10, 02:13:36, FastEthernet0/1
O 172.16.2.0/24 [110/2] via 172.16.110.10, 02:13:36, FastEthernet0/1
O 172.16.3.0/24 [110/2] via 172.16.110.10, 02:13:36, FastEthernet0/1
C 172.16.110.0/24 is directly connected, FastEthernet0/1
L 172.16.110.1/32 is directly connected, FastEthernet0/1
 192.168.1.0/32 is subnetted, 10 subnets
C 192.168.1.1 is directly connected, Loopback0
i L2 192.168.1.2 [115/10] via 10.1.123.2, 02:14:25, FastEthernet0/0
i L2 192.168.1.3 [115/10] via 10.1.123.3, 02:14:12, FastEthernet0/0
i L2 192.168.1.4 [115/20] via 10.1.123.3, 02:14:12, FastEthernet0/0
 [115/20] via 10.1.123.2, 02:14:12, FastEthernet0/0
i L2 192.168.1.5 [115/20] via 10.1.123.2, 02:14:12, FastEthernet0/0
i L2 192.168.1.6 [115/30] via 10.1.123.3, 02:14:02, FastEthernet0/0
 [115/30] via 10.1.123.2, 02:14:02, FastEthernet0/0
i L2 192.168.1.7 [115/30] via 10.1.123.2, 02:14:12, FastEthernet0/0
i L2 192.168.1.8 [115/20] via 10.1.123.3, 02:14:12, FastEthernet0/0
i L2 192.168.1.9 [115/30] via 10.1.123.3, 02:14:02, FastEthernet0/0
O 192.168.1.10 [110/2] via 172.16.110.10, 02:13:36, FastEthernet0/1


R2#show ip route | beg Gate
Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 13 subnets, 2 masks
C 10.1.24.0/24 is directly connected, FastEthernet1/0
L 10.1.24.2/32 is directly connected, FastEthernet1/0
C 10.1.25.0/24 is directly connected, FastEthernet0/1
L 10.1.25.2/32 is directly connected, FastEthernet0/1
i L2 10.1.34.0/24 [115/20] via 10.1.123.3, 02:14:10, FastEthernet0/0
 [115/20] via 10.1.24.4, 02:14:10, FastEthernet1/0
i L2 10.1.38.0/24 [115/20] via 10.1.123.3, 02:14:10, FastEthernet0/0
i L2 10.1.46.0/24 [115/20] via 10.1.24.4, 02:14:10, FastEthernet1/0
i L2 10.1.56.0/24 [115/20] via 10.1.25.5, 02:14:10, FastEthernet0/1
i L2 10.1.57.0/24 [115/20] via 10.1.25.5, 02:14:10, FastEthernet0/1
i L2 10.1.67.0/24 [115/30] via 10.1.25.5, 02:14:00, FastEthernet0/1
 [115/30] via 10.1.24.4, 02:14:00, FastEthernet1/0
i L2 10.1.89.0/24 [115/30] via 10.1.123.3, 02:14:10, FastEthernet0/0
C 10.1.123.0/24 is directly connected, FastEthernet0/0
L 10.1.123.2/32 is directly connected, FastEthernet0/0
 172.16.0.0/24 is subnetted, 5 subnets
i L2 172.16.0.0 [115/10] via 10.1.123.1, 02:13:35, FastEthernet0/0
i L2 172.16.1.0 [115/10] via 10.1.123.1, 02:13:35, FastEthernet0/0
i L2 172.16.2.0 [115/10] via 10.1.123.1, 02:13:35, FastEthernet0/0
i L2 172.16.3.0 [115/10] via 10.1.123.1, 02:13:35, FastEthernet0/0
i L2 172.16.110.0 [115/10] via 10.1.123.1, 02:14:20, FastEthernet0/0
 192.168.1.0/32 is subnetted, 10 subnets
i L2 192.168.1.1 [115/10] via 10.1.123.1, 02:14:20, FastEthernet0/0
C 192.168.1.2 is directly connected, Loopback0
i L2 192.168.1.3 [115/10] via 10.1.123.3, 02:14:10, FastEthernet0/0
i L2 192.168.1.4 [115/10] via 10.1.24.4, 02:14:10, FastEthernet1/0
i L2 192.168.1.5 [115/10] via 10.1.25.5, 02:14:10, FastEthernet0/1
i L2 192.168.1.6 [115/20] via 10.1.25.5, 02:14:00, FastEthernet0/1
 [115/20] via 10.1.24.4, 02:14:00, FastEthernet1/0
i L2 192.168.1.7 [115/20] via 10.1.25.5, 02:14:10, FastEthernet0/1
i L2 192.168.1.8 [115/20] via 10.1.123.3, 02:14:10, FastEthernet0/0
i L2 192.168.1.9 [115/30] via 10.1.123.3, 02:14:00, FastEthernet0/0
i L2 192.168.1.10 [115/10] via 10.1.123.1, 02:13:35, FastEthernet0/0


R3#show ip route | beg Gate
Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 13 subnets, 2 masks
i L2 10.1.24.0/24 [115/20] via 10.1.123.2, 02:14:14, FastEthernet0/0
 [115/20] via 10.1.34.4, 02:14:14, FastEthernet1/0
i L2 10.1.25.0/24 [115/20] via 10.1.123.2, 02:14:14, FastEthernet0/0
C 10.1.34.0/24 is directly connected, FastEthernet1/0
L 10.1.34.3/32 is directly connected, FastEthernet1/0
C 10.1.38.0/24 is directly connected, FastEthernet0/1
L 10.1.38.3/32 is directly connected, FastEthernet0/1
i L2 10.1.46.0/24 [115/20] via 10.1.34.4, 02:14:14, FastEthernet1/0
i L2 10.1.56.0/24 [115/30] via 10.1.123.2, 02:14:14, FastEthernet0/0
 [115/30] via 10.1.34.4, 02:14:14, FastEthernet1/0
i L2 10.1.57.0/24 [115/30] via 10.1.123.2, 02:14:14, FastEthernet0/0
i L2 10.1.67.0/24 [115/30] via 10.1.34.4, 02:14:14, FastEthernet1/0
i L2 10.1.89.0/24 [115/20] via 10.1.38.8, 02:14:14, FastEthernet0/1
C 10.1.123.0/24 is directly connected, FastEthernet0/0
L 10.1.123.3/32 is directly connected, FastEthernet0/0
 172.16.0.0/24 is subnetted, 5 subnets
i L2 172.16.0.0 [115/10] via 10.1.123.1, 02:13:35, FastEthernet0/0
i L2 172.16.1.0 [115/10] via 10.1.123.1, 02:13:35, FastEthernet0/0
i L2 172.16.2.0 [115/10] via 10.1.123.1, 02:13:35, FastEthernet0/0
i L2 172.16.3.0 [115/10] via 10.1.123.1, 02:13:35, FastEthernet0/0
i L2 172.16.110.0 [115/10] via 10.1.123.1, 02:14:14, FastEthernet0/0
 192.168.1.0/32 is subnetted, 10 subnets
i L2 192.168.1.1 [115/10] via 10.1.123.1, 02:14:14, FastEthernet0/0
i L2 192.168.1.2 [115/10] via 10.1.123.2, 02:14:14, FastEthernet0/0
C 192.168.1.3 is directly connected, Loopback0
i L2 192.168.1.4 [115/10] via 10.1.34.4, 02:14:14, FastEthernet1/0
i L2 192.168.1.5 [115/20] via 10.1.123.2, 02:14:14, FastEthernet0/0
i L2 192.168.1.6 [115/20] via 10.1.34.4, 02:14:14, FastEthernet1/0
i L2 192.168.1.7 [115/30] via 10.1.123.2, 02:14:14, FastEthernet0/0
 [115/30] via 10.1.34.4, 02:14:14, FastEthernet1/0
i L2 192.168.1.8 [115/10] via 10.1.38.8, 02:14:14, FastEthernet0/1
i L2 192.168.1.9 [115/20] via 10.1.38.8, 02:14:04, FastEthernet0/1
i L2 192.168.1.10 [115/10] via 10.1.123.1, 02:13:35, FastEthernet0/0


R4#show ip route | beg Gate
Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 13 subnets, 2 masks
C 10.1.24.0/24 is directly connected, FastEthernet1/0
L 10.1.24.4/32 is directly connected, FastEthernet1/0
i L2 10.1.25.0/24 [115/20] via 10.1.24.2, 02:14:16, FastEthernet1/0
C 10.1.34.0/24 is directly connected, FastEthernet0/0
L 10.1.34.4/32 is directly connected, FastEthernet0/0
i L2 10.1.38.0/24 [115/20] via 10.1.34.3, 02:14:06, FastEthernet0/0
C 10.1.46.0/24 is directly connected, FastEthernet0/1
L 10.1.46.4/32 is directly connected, FastEthernet0/1
i L2 10.1.56.0/24 [115/20] via 10.1.46.6, 02:14:06, FastEthernet0/1
i L2 10.1.57.0/24 [115/30] via 10.1.46.6, 02:14:06, FastEthernet0/1
 [115/30] via 10.1.24.2, 02:14:06, FastEthernet1/0
i L2 10.1.67.0/24 [115/20] via 10.1.46.6, 02:14:06, FastEthernet0/1
i L2 10.1.89.0/24 [115/30] via 10.1.34.3, 02:14:06, FastEthernet0/0
i L2 10.1.123.0/24 [115/20] via 10.1.34.3, 02:14:06, FastEthernet0/0
 [115/20] via 10.1.24.2, 02:14:06, FastEthernet1/0
 172.16.0.0/24 is subnetted, 5 subnets
i L2 172.16.0.0 [115/20] via 10.1.34.3, 02:13:35, FastEthernet0/0
 [115/20] via 10.1.24.2, 02:13:35, FastEthernet1/0
i L2 172.16.1.0 [115/20] via 10.1.34.3, 02:13:35, FastEthernet0/0
 [115/20] via 10.1.24.2, 02:13:35, FastEthernet1/0
i L2 172.16.2.0 [115/20] via 10.1.34.3, 02:13:35, FastEthernet0/0
 [115/20] via 10.1.24.2, 02:13:35, FastEthernet1/0
i L2 172.16.3.0 [115/20] via 10.1.34.3, 02:13:35, FastEthernet0/0
 [115/20] via 10.1.24.2, 02:13:35, FastEthernet1/0
i L2 172.16.110.0 [115/20] via 10.1.34.3, 02:14:06, FastEthernet0/0
 [115/20] via 10.1.24.2, 02:14:06, FastEthernet1/0
 192.168.1.0/32 is subnetted, 10 subnets
i L2 192.168.1.1 [115/20] via 10.1.34.3, 02:14:06, FastEthernet0/0
 [115/20] via 10.1.24.2, 02:14:06, FastEthernet1/0
i L2 192.168.1.2 [115/10] via 10.1.24.2, 02:14:16, FastEthernet1/0
i L2 192.168.1.3 [115/10] via 10.1.34.3, 02:14:06, FastEthernet0/0
C 192.168.1.4 is directly connected, Loopback0
i L2 192.168.1.5 [115/20] via 10.1.46.6, 02:14:06, FastEthernet0/1
 [115/20] via 10.1.24.2, 02:14:06, FastEthernet1/0
i L2 192.168.1.6 [115/10] via 10.1.46.6, 02:14:06, FastEthernet0/1
i L2 192.168.1.7 [115/20] via 10.1.46.6, 02:14:06, FastEthernet0/1
i L2 192.168.1.8 [115/20] via 10.1.34.3, 02:14:06, FastEthernet0/0
i L2 192.168.1.9 [115/30] via 10.1.34.3, 02:14:06, FastEthernet0/0
i L2 192.168.1.10 [115/20] via 10.1.34.3, 02:13:35, FastEthernet0/0
 [115/20] via 10.1.24.2, 02:13:35, FastEthernet1/0

R5#show ip route | beg Gate
Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 13 subnets, 2 masks
i L2 10.1.24.0/24 [115/20] via 10.1.25.2, 02:14:16, FastEthernet0/1
C 10.1.25.0/24 is directly connected, FastEthernet0/1
L 10.1.25.5/32 is directly connected, FastEthernet0/1
i L2 10.1.34.0/24 [115/30] via 10.1.56.6, 02:14:06, FastEthernet1/0
 [115/30] via 10.1.25.2, 02:14:06, FastEthernet0/1
i L2 10.1.38.0/24 [115/30] via 10.1.25.2, 02:14:06, FastEthernet0/1
i L1 10.1.46.0/24 [115/20] via 10.1.56.6, 02:14:06, FastEthernet1/0
C 10.1.56.0/24 is directly connected, FastEthernet1/0
L 10.1.56.5/32 is directly connected, FastEthernet1/0
C 10.1.57.0/24 is directly connected, FastEthernet0/0
L 10.1.57.5/32 is directly connected, FastEthernet0/0
i L1 10.1.67.0/24 [115/20] via 10.1.56.6, 02:14:06, FastEthernet1/0
i L2 10.1.89.0/24 [115/40] via 10.1.25.2, 02:14:06, FastEthernet0/1
i L2 10.1.123.0/24 [115/20] via 10.1.25.2, 02:14:16, FastEthernet0/1
 172.16.0.0/24 is subnetted, 5 subnets
i L2 172.16.0.0 [115/20] via 10.1.25.2, 02:13:34, FastEthernet0/1
i L2 172.16.1.0 [115/20] via 10.1.25.2, 02:13:34, FastEthernet0/1
i L2 172.16.2.0 [115/20] via 10.1.25.2, 02:13:34, FastEthernet0/1
i L2 172.16.3.0 [115/20] via 10.1.25.2, 02:13:34, FastEthernet0/1
i L2 172.16.110.0 [115/20] via 10.1.25.2, 02:14:16, FastEthernet0/1
 192.168.1.0/32 is subnetted, 10 subnets
i L2 192.168.1.1 [115/20] via 10.1.25.2, 02:14:16, FastEthernet0/1
i L2 192.168.1.2 [115/10] via 10.1.25.2, 02:14:16, FastEthernet0/1
i L2 192.168.1.3 [115/20] via 10.1.25.2, 02:14:06, FastEthernet0/1
i L2 192.168.1.4 [115/20] via 10.1.56.6, 02:14:06, FastEthernet1/0
 [115/20] via 10.1.25.2, 02:14:06, FastEthernet0/1
C 192.168.1.5 is directly connected, Loopback0
i L1 192.168.1.6 [115/10] via 10.1.56.6, 02:14:06, FastEthernet1/0
i L1 192.168.1.7 [115/10] via 10.1.57.7, 02:14:16, FastEthernet0/0
i L2 192.168.1.8 [115/30] via 10.1.25.2, 02:14:06, FastEthernet0/1
i L2 192.168.1.9 [115/40] via 10.1.25.2, 02:14:06, FastEthernet0/1
i L2 192.168.1.10 [115/20] via 10.1.25.2, 02:13:34, FastEthernet0/1

R6#show ip route | beg Gate
Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 13 subnets, 2 masks
i L2 10.1.24.0/24 [115/20] via 10.1.46.4, 02:14:14, FastEthernet0/1
i L1 10.1.25.0/24 [115/20] via 10.1.56.5, 02:14:14, FastEthernet1/0
i L2 10.1.34.0/24 [115/20] via 10.1.46.4, 02:14:14, FastEthernet0/1
i L2 10.1.38.0/24 [115/30] via 10.1.46.4, 02:14:04, FastEthernet0/1
C 10.1.46.0/24 is directly connected, FastEthernet0/1
L 10.1.46.6/32 is directly connected, FastEthernet0/1
C 10.1.56.0/24 is directly connected, FastEthernet1/0
L 10.1.56.6/32 is directly connected, FastEthernet1/0
i L1 10.1.57.0/24 [115/20] via 10.1.67.7, 02:14:14, FastEthernet0/0
 [115/20] via 10.1.56.5, 02:14:14, FastEthernet1/0
C 10.1.67.0/24 is directly connected, FastEthernet0/0
L 10.1.67.6/32 is directly connected, FastEthernet0/0
i L2 10.1.89.0/24 [115/40] via 10.1.46.4, 02:14:04, FastEthernet0/1
i L2 10.1.123.0/24 [115/30] via 10.1.56.5, 02:14:04, FastEthernet1/0
 [115/30] via 10.1.46.4, 02:14:04, FastEthernet0/1
 172.16.0.0/24 is subnetted, 5 subnets
i L2 172.16.0.0 [115/30] via 10.1.56.5, 02:13:35, FastEthernet1/0
 [115/30] via 10.1.46.4, 02:13:35, FastEthernet0/1
i L2 172.16.1.0 [115/30] via 10.1.56.5, 02:13:35, FastEthernet1/0
 [115/30] via 10.1.46.4, 02:13:35, FastEthernet0/1
i L2 172.16.2.0 [115/30] via 10.1.56.5, 02:13:35, FastEthernet1/0
 [115/30] via 10.1.46.4, 02:13:35, FastEthernet0/1
i L2 172.16.3.0 [115/30] via 10.1.56.5, 02:13:35, FastEthernet1/0
 [115/30] via 10.1.46.4, 02:13:35, FastEthernet0/1
i L2 172.16.110.0 [115/30] via 10.1.56.5, 02:14:04, FastEthernet1/0
 [115/30] via 10.1.46.4, 02:14:04, FastEthernet0/1
 192.168.1.0/32 is subnetted, 10 subnets
i L2 192.168.1.1 [115/30] via 10.1.56.5, 02:14:04, FastEthernet1/0
 [115/30] via 10.1.46.4, 02:14:04, FastEthernet0/1
i L2 192.168.1.2 [115/20] via 10.1.56.5, 02:14:04, FastEthernet1/0
 [115/20] via 10.1.46.4, 02:14:04, FastEthernet0/1
i L2 192.168.1.3 [115/20] via 10.1.46.4, 02:14:04, FastEthernet0/1
i L2 192.168.1.4 [115/10] via 10.1.46.4, 02:14:14, FastEthernet0/1
i L1 192.168.1.5 [115/10] via 10.1.56.5, 02:14:14, FastEthernet1/0
C 192.168.1.6 is directly connected, Loopback0
i L1 192.168.1.7 [115/10] via 10.1.67.7, 02:14:14, FastEthernet0/0
i L2 192.168.1.8 [115/30] via 10.1.46.4, 02:14:04, FastEthernet0/1
i L2 192.168.1.9 [115/40] via 10.1.46.4, 02:14:04, FastEthernet0/1
i L2 192.168.1.10 [115/30] via 10.1.56.5, 02:13:35, FastEthernet1/0
 [115/30] via 10.1.46.4, 02:13:35, FastEthernet0/1


R7#show ip route | beg Gate
Gateway of last resort is 10.1.57.5 to network 0.0.0.0

i*L1 0.0.0.0/0 [115/10] via 10.1.57.5, 02:14:15, FastEthernet0/0
 10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
i L1 10.1.25.0/24 [115/20] via 10.1.57.5, 02:14:15, FastEthernet0/0
i L1 10.1.46.0/24 [115/30] via 10.1.67.6, 02:14:05, FastEthernet0/1
 [115/30] via 10.1.57.5, 02:14:05, FastEthernet0/0
i L1 10.1.56.0/24 [115/20] via 10.1.57.5, 02:14:15, FastEthernet0/0
C 10.1.57.0/24 is directly connected, FastEthernet0/0
L 10.1.57.7/32 is directly connected, FastEthernet0/0
C 10.1.67.0/24 is directly connected, FastEthernet0/1
L 10.1.67.7/32 is directly connected, FastEthernet0/1
 192.168.1.0/32 is subnetted, 3 subnets
i L1 192.168.1.5 [115/10] via 10.1.57.5, 02:14:15, FastEthernet0/0
i L1 192.168.1.6 [115/20] via 10.1.67.6, 02:14:05, FastEthernet0/1
 [115/20] via 10.1.57.5, 02:14:05, FastEthernet0/0
C 192.168.1.7 is directly connected, Loopback0


R8#show ip route | beg Gate
Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
i L2 10.1.24.0/24 [115/30] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 10.1.25.0/24 [115/30] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 10.1.34.0/24 [115/20] via 10.1.38.3, 02:14:08, FastEthernet0/1
C 10.1.38.0/24 is directly connected, FastEthernet0/1
L 10.1.38.8/32 is directly connected, FastEthernet0/1
i L2 10.1.46.0/24 [115/30] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 10.1.56.0/24 [115/40] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 10.1.57.0/24 [115/40] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 10.1.67.0/24 [115/40] via 10.1.38.3, 02:14:08, FastEthernet0/1
C 10.1.89.0/24 is directly connected, FastEthernet0/0
L 10.1.89.8/32 is directly connected, FastEthernet0/0
i L2 10.1.123.0/24 [115/20] via 10.1.38.3, 02:14:08, FastEthernet0/1
 172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
i su 172.16.0.0/22 [115/20] via 0.0.0.0, 02:13:35, Null0 << Summary
i L2 172.16.0.0/24 [115/20] via 10.1.38.3, 02:13:35, FastEthernet0/1
i L2 172.16.1.0/24 [115/20] via 10.1.38.3, 02:13:35, FastEthernet0/1
i L2 172.16.2.0/24 [115/20] via 10.1.38.3, 02:13:35, FastEthernet0/1
i L2 172.16.3.0/24 [115/20] via 10.1.38.3, 02:13:35, FastEthernet0/1
i L2 172.16.110.0/24 [115/20] via 10.1.38.3, 02:14:08, FastEthernet0/1
 192.168.1.0/32 is subnetted, 10 subnets
i L2 192.168.1.1 [115/20] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 192.168.1.2 [115/20] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 192.168.1.3 [115/10] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 192.168.1.4 [115/20] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 192.168.1.5 [115/30] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 192.168.1.6 [115/30] via 10.1.38.3, 02:14:08, FastEthernet0/1
i L2 192.168.1.7 [115/40] via 10.1.38.3, 02:14:08, FastEthernet0/1
C 192.168.1.8 is directly connected, Loopback0
i L1 192.168.1.9 [115/10] via 10.1.89.9, 02:14:08, FastEthernet0/0
i L2 192.168.1.10 [115/20] via 10.1.38.3, 02:13:35, FastEthernet0/1


R8#sh isis database detail

Tag 1:
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R8.00-00 * 0x0000000E 0x1EF5 756 1/0/0
 Area Address: 49.0003
 NLPID: 0xCC 
 Hostname: R8
 IP Address: 192.168.1.8
 Metric: 10 IP 10.1.89.0 255.255.255.0
 Metric: 10 IP 10.1.38.0 255.255.255.0
 Metric: 0 IP 192.168.1.8 255.255.255.255
 Metric: 10 IS R9.01
 Metric: 158 IP-Interarea 10.1.24.0 255.255.255.0
 Metric: 158 IP-Interarea 10.1.25.0 255.255.255.0
 Metric: 148 IP-Interarea 10.1.34.0 255.255.255.0
 Metric: 158 IP-Interarea 10.1.46.0 255.255.255.0
 Metric: 168 IP-Interarea 10.1.56.0 255.255.255.0
 Metric: 168 IP-Interarea 10.1.57.0 255.255.255.0
 Metric: 168 IP-Interarea 10.1.67.0 255.255.255.0
 Metric: 148 IP-Interarea 10.1.123.0 255.255.255.0
 Metric: 148 IP-Interarea 172.16.110.0 255.255.255.0
 Metric: 148 IP-Interarea 192.168.1.1 255.255.255.255
 Metric: 148 IP-Interarea 192.168.1.2 255.255.255.255
 Metric: 138 IP-Interarea 192.168.1.3 255.255.255.255
 Metric: 148 IP-Interarea 192.168.1.4 255.255.255.255
 Metric: 158 IP-Interarea 192.168.1.5 255.255.255.255
 Metric: 158 IP-Interarea 192.168.1.6 255.255.255.255
 Metric: 168 IP-Interarea 192.168.1.7 255.255.255.255
 Metric: 148 IP-Interarea 192.168.1.10 255.255.255.255
 Metric: 148 IP-Interarea 172.16.0.0 255.255.252.0
R9.00-00 0x0000000D 0xD6D4 1140 0/0/0
 Area Address: 49.0003
 NLPID: 0xCC 
 Hostname: R9
 IP Address: 192.168.1.9
 Metric: 10 IP 10.1.89.0 255.255.255.0
 Metric: 0 IP 192.168.1.9 255.255.255.255
 Metric: 10 IS R9.01
R9.01-00 0x0000000B 0x0418 469 0/0/0
 Metric: 0 IS R9.00
 Metric: 0 IS R8.00
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 0x0000000E 0x69D5 668 0/0/0
 Area Address: 49.0001
 NLPID: 0xCC 
 Hostname: R1
 IP Address: 192.168.1.1
 Metric: 10 IS R3.01
 Metric: 10 IP 10.1.123.0 255.255.255.0
 Metric: 0 IP-External 172.16.0.0 255.255.255.0
 Metric: 0 IP-External 172.16.1.0 255.255.255.0
 Metric: 0 IP-External 172.16.2.0 255.255.255.0
 Metric: 0 IP-External 172.16.3.0 255.255.255.0
 Metric: 0 IP-External 172.16.110.0 255.255.255.0
 Metric: 0 IP 192.168.1.1 255.255.255.255
 Metric: 0 IP-External 192.168.1.10 255.255.255.255
R2.00-00 0x0000000E 0x7B1B 473 0/0/0
 Area Address: 49.0001
 NLPID: 0xCC 
 Hostname: R2
 IP Address: 192.168.1.2
 Metric: 10 IS R2.02
 Metric: 10 IS R3.01
 Metric: 10 IS R4.03
 Metric: 10 IP 10.1.24.0 255.255.255.0
 Metric: 10 IP 10.1.25.0 255.255.255.0
 Metric: 10 IP 10.1.123.0 255.255.255.0
 Metric: 0 IP 192.168.1.2 255.255.255.255
R2.02-00 0x0000000B 0x1999 388 0/0/0
 Metric: 0 IS R2.00
 Metric: 0 IS R5.00
R3.00-00 0x0000000C 0x423B 964 0/0/0
 Area Address: 49.0001
 NLPID: 0xCC 
 Hostname: R3
 IP Address: 192.168.1.3
 Metric: 10 IS R3.03
 Metric: 10 IS R3.02
 Metric: 10 IS R3.01
 Metric: 10 IP 10.1.34.0 255.255.255.0
 Metric: 10 IP 10.1.38.0 255.255.255.0
 Metric: 10 IP 10.1.123.0 255.255.255.0
 Metric: 0 IP 192.168.1.3 255.255.255.255
R3.01-00 0x0000000B 0xACC7 528 0/0/0
 Metric: 0 IS R3.00
 Metric: 0 IS R1.00
 Metric: 0 IS R2.00
R3.02-00 0x0000000B 0x6A43 674 0/0/0
 Metric: 0 IS R3.00
 Metric: 0 IS R8.00
R3.03-00 0x0000000B 0xFEB1 678 0/0/0
 Metric: 0 IS R3.00
 Metric: 0 IS R4.00
R4.00-00 0x0000000E 0x3F0F 599 0/0/0
 Area Address: 49.0001
 NLPID: 0xCC 
 Hostname: R4
 IP Address: 192.168.1.4
 Metric: 10 IP 10.1.34.0 255.255.255.0
 Metric: 10 IP 10.1.46.0 255.255.255.0
 Metric: 10 IP 10.1.24.0 255.255.255.0
 Metric: 10 IS R4.03
 Metric: 10 IS R4.02
 Metric: 10 IS R3.03
 Metric: 0 IP 192.168.1.4 255.255.255.255
R4.02-00 0x0000000B 0x3E6F 597 0/0/0
 Metric: 0 IS R4.00
 Metric: 0 IS R6.00
R4.03-00 0x0000000C 0xD0DE 817 0/0/0
 Metric: 0 IS R4.00
 Metric: 0 IS R2.00
R5.00-00 0x0000000F 0xEE2B 589 0/0/0
 Area Address: 49.0002
 NLPID: 0xCC 
 Hostname: R5
 IP Address: 192.168.1.5
 Metric: 10 IS R2.02
 Metric: 10 IS R6.03
 Metric: 10 IP 10.1.25.0 255.255.255.0
 Metric: 20 IP 10.1.46.0 255.255.255.0
 Metric: 10 IP 10.1.56.0 255.255.255.0
 Metric: 10 IP 10.1.57.0 255.255.255.0
 Metric: 20 IP 10.1.67.0 255.255.255.0
 Metric: 0 IP 192.168.1.5 255.255.255.255
 Metric: 10 IP 192.168.1.6 255.255.255.255
 Metric: 10 IP 192.168.1.7 255.255.255.255
R6.00-00 0x0000000E 0xC253 712 0/0/0
 Area Address: 49.0002
 NLPID: 0xCC 
 Hostname: R6
 IP Address: 192.168.1.6
 Metric: 10 IS R6.03
 Metric: 10 IS R4.02
 Metric: 20 IP 10.1.25.0 255.255.255.0
 Metric: 10 IP 10.1.46.0 255.255.255.0
 Metric: 10 IP 10.1.56.0 255.255.255.0
 Metric: 20 IP 10.1.57.0 255.255.255.0
 Metric: 10 IP 10.1.67.0 255.255.255.0
 Metric: 10 IP 192.168.1.5 255.255.255.255
 Metric: 0 IP 192.168.1.6 255.255.255.255
 Metric: 10 IP 192.168.1.7 255.255.255.255
R6.03-00 0x0000000C 0x2880 993 0/0/0
 Metric: 0 IS R6.00
 Metric: 0 IS R5.00
R8.00-00 * 0x0000000E 0xB32A 983 0/0/0
 Area Address: 49.0003
 NLPID: 0xCC 
 Hostname: R8
 IP Address: 192.168.1.8
 Metric: 10 IS R3.02
 Metric: 10 IP 10.1.38.0 255.255.255.0
 Metric: 10 IP 10.1.89.0 255.255.255.0
 Metric: 0 IP 192.168.1.8 255.255.255.255
 Metric: 10 IP 192.168.1.9 255.255.255.255


R9#show ip route | beg Gate
Gateway of last resort is 10.1.89.8 to network 0.0.0.0

i*L1 0.0.0.0/0 [115/10] via 10.1.89.8, 02:14:01, FastEthernet0/0
 10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
i ia 10.1.24.0/24 [115/168] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 10.1.25.0/24 [115/168] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 10.1.34.0/24 [115/158] via 10.1.89.8, 02:14:01, FastEthernet0/0
i L1 10.1.38.0/24 [115/20] via 10.1.89.8, 02:14:18, FastEthernet0/0
i ia 10.1.46.0/24 [115/168] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 10.1.56.0/24 [115/178] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 10.1.57.0/24 [115/178] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 10.1.67.0/24 [115/178] via 10.1.89.8, 02:14:01, FastEthernet0/0
C 10.1.89.0/24 is directly connected, FastEthernet0/0
L 10.1.89.9/32 is directly connected, FastEthernet0/0
i ia 10.1.123.0/24 [115/158] via 10.1.89.8, 02:14:01, FastEthernet0/0
 172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
i ia 172.16.0.0/22 [115/158] via 10.1.89.8, 02:13:32, FastEthernet0/0
i ia 172.16.110.0/24 [115/158] via 10.1.89.8, 02:14:01, FastEthernet0/0
 192.168.1.0/32 is subnetted, 10 subnets
i ia 192.168.1.1 [115/158] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 192.168.1.2 [115/158] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 192.168.1.3 [115/148] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 192.168.1.4 [115/158] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 192.168.1.5 [115/168] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 192.168.1.6 [115/168] via 10.1.89.8, 02:14:01, FastEthernet0/0
i ia 192.168.1.7 [115/178] via 10.1.89.8, 02:14:01, FastEthernet0/0
i L1 192.168.1.8 [115/10] via 10.1.89.8, 02:14:18, FastEthernet0/0
C 192.168.1.9 is directly connected, Loopback0
i ia 192.168.1.10 [115/158] via 10.1.89.8, 02:13:32, FastEthernet0/0


R10#show ip route | beg Gate
Gateway of last resort is not set

10.0.0.0/24 is subnetted, 9 subnets
O E2 10.1.24.0 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 10.1.25.0 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 10.1.34.0 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 10.1.38.0 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 10.1.46.0 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 10.1.56.0 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 10.1.57.0 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 10.1.67.0 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 10.1.89.0 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
 172.16.0.0/16 is variably subnetted, 10 subnets, 2 masks
C 172.16.0.0/24 is directly connected, Loopback1
L 172.16.0.1/32 is directly connected, Loopback1
C 172.16.1.0/24 is directly connected, Loopback2
L 172.16.1.1/32 is directly connected, Loopback2
C 172.16.2.0/24 is directly connected, Loopback3
L 172.16.2.1/32 is directly connected, Loopback3
C 172.16.3.0/24 is directly connected, Loopback4
L 172.16.3.1/32 is directly connected, Loopback4
C 172.16.110.0/24 is directly connected, FastEthernet0/1
L 172.16.110.10/32 is directly connected, FastEthernet0/1
 192.168.1.0/32 is subnetted, 10 subnets
O 192.168.1.1 [110/2] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 192.168.1.2 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 192.168.1.3 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 192.168.1.4 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 192.168.1.5 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 192.168.1.6 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 192.168.1.7 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 192.168.1.8 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
O E2 192.168.1.9 [110/20] via 172.16.110.1, 02:13:37, FastEthernet0/1
C 192.168.1.10 is directly connected, Loopback0
Ping and Traceroute
!!-- Ping R10 network from R7 --!!

R7#ping 172.16.0.1 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.7 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 128/144/168 ms

!!-- Traceroute R10 network from R7 --!!

R7#traceroute 172.16.0.1 source loopback 0
Type escape sequence to abort.
Tracing the route to 172.16.0.1
VRF info: (vrf in name/id, vrf out name/id)
 1 10.1.57.5 24 msec 68 msec 48 msec
 2 10.1.25.2 80 msec 88 msec 76 msec
 3 10.1.123.1 132 msec 116 msec 108 msec
 4 172.16.110.10 156 msec * 148 msec

!!-- Ping R9 from R7 --!!

R7#ping 192.168.1.9 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.9, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.7 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 180/190/204 ms

!!-- Traceroute R9 from R7 --!!

R7#traceroute 192.168.1.9 source loopback 0
Type escape sequence to abort.
Tracing the route to 192.168.1.9
VRF info: (vrf in name/id, vrf out name/id)
 1 10.1.57.5 32 msec 60 msec 32 msec
 2 10.1.25.2 96 msec 76 msec 76 msec
 3 10.1.123.3 100 msec 124 msec 128 msec
 4 10.1.38.8 164 msec 160 msec 160 msec
 5 10.1.89.9 192 msec * 176 msec

!!-- Ping R10 network from R9 --!!

R9#ping 172.16.1.1 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.9 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 156/164/172 ms

!!-- Traceroute R10 network from R9 --!!

R9#traceroute 172.16.1.1 source loopback 0
Type escape sequence to abort.
Tracing the route to 172.16.1.1
VRF info: (vrf in name/id, vrf out name/id)
 1 10.1.89.8 52 msec 36 msec 44 msec
 2 10.1.38.3 100 msec 72 msec 88 msec
 3 10.1.123.1 120 msec 108 msec 124 msec
 4 172.16.110.10 156 msec * 160 msec

!!-- Ping R7 from R9 --!!

R9#ping 192.168.1.7 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.7, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.9 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 188/193/200 ms

!!-- Traceroute R7 from R9 --!!

R9#traceroute 192.168.1.7 source loopback 0
Type escape sequence to abort.
Tracing the route to 192.168.1.7
VRF info: (vrf in name/id, vrf out name/id)
 1 10.1.89.8 44 msec 48 msec 28 msec
 2 10.1.38.3 100 msec 60 msec 92 msec
 3 10.1.34.4 128 msec 108 msec 116 msec
 4 10.1.46.6 172 msec 164 msec 164 msec
 5 10.1.67.7 192 msec * 196 msec
Print Friendly, PDF & Email

Leave a Reply

Your email address will not be published. Required fields are marked *

*